DodgeTalk Forum banner

Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
Alright i decided to take the EGR valve off today and clean all the crap outta it.All went well put it back together and now it runs like Shit.
Took it off again and looked at everything was fine and put it back together again still runs like shit.Not sure what to do but need to fix it asap i checked to make sure all lines were connected again and all were fine.
Is it possible that EGR was shot but working and after cleaning it won't work?

Please help....
 

·
Banned
Joined
·
95 Posts
What's running like shit?

How is the idle on it? The EGR isn't supposed to open at idle. If it's running rough at idle I would check all the vac lines. If everything checks out then it is possible that the EGR valve is stuck open.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #3
The truck is idling like crap.All was fine until i cleaned the egr which every line was plugged so bad it took 2 hours to clean them all.I rechecked all vacuum and seem fine.
 

·
Registered
Joined
·
385 Posts
I would bet that the valve was, and is stuck open... the carbon that was in there was effectively keeping it closed all the time, hence no issues prior to cleaning it. If you replace the EGR valve now I bet you will see an increase in the way the truck runs above the way it was running prior to cleaning.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #5
Strange but went out before work pulled a vacuum line off the EGR vacuum and truck ran fine.Left it like that and drove to work and home fine.
Still going to get new one as soon as i get the money but does that make any sense that if i pull off the vacuum line it runs fine again?

thanks
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top