DodgeTalk Forum banner

Status
Not open for further replies.
1 - 16 of 16 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
hey guys i'm working on my friends 1989 dakota i cant' get no spark just put new cap rotor plugs &wires on still no spark he also has anouther 89 dakota for parts i was trying to check the truble codes but never got no blinks works on his parts truck so i changed the computer thinking that was the problem but still the same thing also changed the coil anybody got an idea what the problem is oh yeah it's a 3.9 v6
 

·
Registered
Joined
·
356 Posts
sounds like it might be the hal effect sensor, think it called an optic eye on the trucks. its basicly a pick up in the dist. pull the cap and rotor and lift the plate up, see if its corroded. if the parts truck has one, swap it and see if it works, had that happen before. it doesnt show up in the codes.
 

·
old 87 dak
Joined
·
90 Posts
Just had this problem w/ my 87 dak v6, no spark from coil it was the dist. The ring in it broke completely off that fires the spark to the plugs. You might want to pull it out and take it apart and check it.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #5
i changed the distributer with the one from the other truck still nothing the fault code system dosent work at all what would cause that may be thats the proublem
 

·
Registered
Joined
·
1 Posts
no start, no ses (check engine light)

There is a wire harness under power distribution center. ( fuse box ) under the hood drivers side open the harness up there is a connection with I think 2 red wires going into 1 red wire that has a connection. It is probably corroded. Take the splice apart and rewire it. the clue is no ses lite on.
 

·
Registered
Joined
·
510 Posts
When you turn the key on, does the fuel pump run briefly? If not, try swapping the ASD (auto shut down ) relay on the left front fender. This gives power to fuel pump and coil. Try puting positive power to the coil and start. If it runs, then ASD relay is
bad or not getting power. Relay should click as you turn on the key.
 

·
Registered
Joined
·
8 Posts
i was a little confused about what you said. maybe is just that im up late. the truck runs just fine as far as i know. just the tach,speedo and engine light arnt working. first thing that came to mind was a fuse but all of these things use different fuses.
 

·
Registered
Joined
·
1 Posts
I have a 95 Dakota with similar issues. I can drive around then the truck
quites. I'll lose fuel pump and spark then when you try to restart I have
noticed the "check engine" light will not come on, no relays click fuel pump
wont prime up and she's dead. I have noticed the tach will jump out of control
prior to shuting down and then its just a mtter of time, call the wrecker. I have had the wiring in the harness redone as mentioned in an earlier post and even went as far as a new computer, ran for 3 days and is sitting at the shop today waiting to hear
 

·
Registered
Joined
·
31 Posts
had same problem with mine, thought it was a fusible link, after 4 hours, still nothing, ended up being a ignition switch in the bottom of the steering colum, the plastic clip was cracked and broke.
 

·
Registered
Joined
·
12 Posts
first replace the coil and try it then look into the relays specifically the starter relay if it's toast NO SPARK! replace it and you're golden
 

·
4 Wheel Power Disc Brakes
Joined
·
5,828 Posts
The ASD (auto shut down relay) powers the computer as well as supplying power to the injectors and coil.... So if the injectors don't click also, the problem could be here since no check engine light is being displayed. (I assume the check engine lights if the ignition is turned to the run position, without cranking)
--B-300--
 
1 - 16 of 16 Posts
Status
Not open for further replies.
Top