DodgeTalk Forum banner

Status
Not open for further replies.
1 - 19 of 19 Posts

·
Registered
Joined
·
40 Posts
Discussion Starter #1
Ok, This is my first post. I have been under a few otehr forums but none with my Dodge. So I have a 1998 Ram 1500 excab 318 4x4 sport. I got the truck a few weeks ago and it was running fine. I mess around with it alittle off road and got it stuck. Well after we pulled it out we noticed the tranny wasnt downshifting into 1st when I come to a stop all the time and sometimes shifts real hard. I drained all the fluid and replaced it and replaced the filter. Then too it up to Valveline and had the flush the system again and its still acting up. I have a warrenty but im not sure what it will cover at this time. I would like to fix it myself as I am good with cars. Any ideas? Thanks again for the help everyone!
 

·
Tracker81
Joined
·
74 Posts
Is the Check engine light on? and also on the driver side you have the shift linkage and a small spring on the side of the tranny make sure that the linkage is free of dirt and bends and that the spring is not damaged. Could possibly be internal if so probably time for a new governor pressure solenoid anyway. Oh will the tranny shift if you pull it down into first
 

·
Registered
Joined
·
40 Posts
Discussion Starter #3
No the CEL is not on. Ill check the linkage tomorrow. If I pull it inot 1st its fine or if I put it into park then back into drive its fine. Its just mostly when it gets warmed up. It shifts real hard from 1st -2nd.
 

·
Tracker81
Joined
·
74 Posts
Governor Pressure Solenoid sounds like it has picked up some trash you can replace it if you have some mechanical know how, if not the solenoid isnt that expensive if you take the pan off it should be located on the passenger side of the valve body and if you do the solenoid you mine as well do the other sensor in there
 

·
Registered
Joined
·
40 Posts
Discussion Starter #5
Ok, there are several switches under there. Im lookin at the NAPA site right now and there showing a 'A/trans Solenoid' (one for 'governor' and one for 'Overdrive Lock-up)and the 'Governor Pressure Sensor'. I assume your talking about the Gov pressure sensor but I just wanna be clear. At 100bucks a each I dont wanna have to replace what I dont have to. Thanks for the help
 

·
Transmission Man!
Joined
·
3,508 Posts
here's a pic
 

Attachments

·
Registered
Joined
·
40 Posts
Discussion Starter #7
Thanks for the diagram, but it still isnt answering my question. I put some Lucas tranny stuff in there (technical eh) and it cleaned up some of the shifting issue but im sill having the issue of it shifting back into 1st when its supposed to. Everything else if fine...its just not shifting into 1st when I slow down or come to a stop. And like I said...most of the time its when its warm.

I talked to a few people I know and some said it needs to be rebuilt with seals and paper...but I dont know if thats going to fix it. He also said it might be a stuck valve body...but since I put that Lucas stuff in there and its still doing it...I lead to believe not. If the Gov pressure sensor/solenoid was back, I would lead to believe it would effect more then just 1st gear.
 

·
Tracker81
Joined
·
74 Posts
Both of the sensors/solenoids need to be replaced more than likely if you didnt find any metal or pieces of the snaprings in the pan than shes probably allright the reason for the gear change problem is that the sensor and the solenoid tell the trans when to shift and if the reading is wrong than it will not shift, next the computer also uses a limp in mode in which the truck will not go back into first gear until the readings are correct this allows the truck to be driven some where with the least likely damage to itself and allowing you the option of driving it at higher speeds in the event that some thing was to happen like it is right now and even if this does not work and you have to get a tranny rebuild than the sensors and solenoid are going to be replaced anyhow so you can take these off the cost of a rebuild because they will allready be new. putting fluids in and changing filters is not going to help get the truck fixed the only fluid part that is important is ensuring that your trannsmission is full of fluid. This is a mechanical issue.
 

·
Registered
Joined
·
40 Posts
Discussion Starter #9 (Edited)
Ok, thanks for the help. I suppose that Ill get the sensor and solenoid this week then and put them on.
Another quick question im curious about, why will it downshift into 1st shen its cold but not when its heated up? Maybe cause the solenoid is heating up? Thanks.
 

·
Tracker81
Joined
·
74 Posts
its not really when it is cold It is because when you turn the truck off the computer resets and so when you get back in to drive again your back in first. next time you come cruising to a stop try putting the truck into neutral cutting it off then starting it back up and the truck should go back into first to keep you from wearing out 2nd gear clutches until you get it fixed
 

·
Tracker81
Joined
·
74 Posts
By the way how many miles are on this tranny and when was the last time the forward and reverse bands were adjusted ?
 

·
Registered
Joined
·
40 Posts
Discussion Starter #12
I have no clue. I have 73000 on the truck itself. Im not sure when the last time the owner got it serviced. I think im going to try the Pressure sensor and solinoid when I get off work today and see if that helps any. I hope it does cause its gonna cost me almost 300 bucks.
 

·
Transmission Man!
Joined
·
3,508 Posts
Reverse band adjustment is on the inside,now would be the time to do it while the pan is off.
 

·
Registered
Joined
·
40 Posts
Discussion Starter #14
Well, I broke down and went to dodge and got the solenoid and the sensor. I went home, drained the pan and replaced the solenoid and found out that the sensor they gave me was the wrong one. I finished everything I could there for the night and put everything back on. The transmission seems to shift ALOT better. Still has a few issues not its 95% better. Im going to go and get the sensor this weekend since im working from 7a-7p today thru friday. Hopefully that will fix EVERYTHING. Thanks for all the help guys.
 

·
Registered
Joined
·
40 Posts
Discussion Starter #15
Ok, I have another issue. I replaced the solenoid the other day, now the truck wont shift from one gear to the next, sorta like its low on fluid but its not. Im going to get the sensor this weekend (sat, since its my first day off work). I assume it is that sensor, but so im sure the sensor is the one that comes out at a 90degree angle and has 4 prongs plugging into a connector. Is this correct? Im just making sure im replacing the right one. Thanks again for the help.
 

·
Transmission Man!
Joined
·
3,508 Posts
Yes ,that is the governor pressure sensor(transducer).
 

·
Registered
Joined
·
40 Posts
Discussion Starter #17
Ok, thanks for the help, Ill get that this weekend and hopefully that will take care of the rest of the issue....Im glad I only drive 6 miles to work.
 

·
Transmission Man!
Joined
·
3,508 Posts
Make sure you check your fluid level in neutral also. ;)
 

·
Registered
Joined
·
40 Posts
Discussion Starter #19
lol Thanks, I already do that.I actually rechecked it last nite since I did the pressure sensor and I topped it off a bit. So its almost perfect now. Do you think that sensor (transducer) is what is cousing this issue?
 
1 - 19 of 19 Posts
Status
Not open for further replies.
Top