DodgeTalk Forum banner

Status
Not open for further replies.
1 - 9 of 9 Posts

·
Registered
Joined
·
48 Posts
Discussion Starter #1
I don't mean that they work on the intermittent 'cycle'. What I mean is that most of the time the wipers work - but sometimes don't. I can't figure out what is making them sometimes decide not to work. I thought maybe one of the relays was bad but I switched two of them (same type relay) and nothing changed.

I am not sure what else to check. Has anyone had this issue?

2002 ram 1500 quad cab, 4.7L

...luckily it hasn't decided to not work in a real downpour yet.... knock on wood
 

·
Registered
Joined
·
6,334 Posts
Try changing the multifunction switch.
 

·
Registered
Joined
·
6,334 Posts
It's pretty simple, pull the steering column covers and swap it out.
 

·
War Eagle!
Joined
·
2,005 Posts
if its not the switch I would say it sounds like the wiper motor may be going out on you. this happened on my honda in a similar fashion back in high school
 

·
Fathead
Joined
·
1,046 Posts
x2 on the multi-function switch (the switch on your steering column that runs wipers, signals, etc.)...
 

·
Registered
Joined
·
48 Posts
Discussion Starter #7
What would be wrong with the switch - a short? or worn connector?

Can those be purchased online or is it better to go with the dealer (dodge part vs aftermarket)? honestly - I haven't looked yet.

Question - is there a way to check it before replacing? I would hate to spend the money to replace then find out that wasn't the problem (as any of us would).

Thanks
 

·
Registered
Joined
·
683 Posts
The switch is cheap, about $50 from rockauto. Replacing it is a little more involved, you have to pull the whole steering wheel.

I've got the same problem as you as well as intermittent problems with the signals not working or the wrong one comes on. The switch is still sitting in my garage until I can rent a puller and find the time to do the work.

But there's no way of testing it that I'm aware of.
 

·
PAID OFF!!!
Joined
·
7,637 Posts
I had the multi function switch changed twice under warranty. Had the same symptoms as the poster.
 
1 - 9 of 9 Posts
Status
Not open for further replies.
Top