DodgeTalk Forum banner
Status
Not open for further replies.
1 - 8 of 8 Posts

·
Vertically-Challenged
Joined
·
12,020 Posts
Discussion Starter · #1 ·
Well today i noticed that thier is a wierd sqweeking sound and sometimes theres some grinding noises a little after i take off from a dead stop. I just got new exhaust and i dont think that is it. I think it is the rear brakes catching a little bit and making noise. Has anyone had this before or does anyone have any other ideas? Im calling the dealership tomorrow morning and would appreciate anything that you guys might think.

BTW-it was also raining today if that helps. Thanks

Sam
 

·
Registered
Joined
·
2,616 Posts
Have them check your shock mount bolts. Mine did the same thing. It was the left rear side. I would stil check them both.
If it is the problem, they will just retourque the bolts.
 

·
Vertically-Challenged
Joined
·
12,020 Posts
Discussion Starter · #3 ·
Yeah, LeSchwab told me to come in at 500 miles afterwords to get tem re-torqued and it has been about 1600 miles due to being real busy and not able to get back there. My noise is on the rear right side. Thanks for the quick reply.
 

·
Registered
Joined
·
2,616 Posts
Anytime!
I just realized when I read my post. It was the right rear side and not the left..........Sorry about that.
 

·
Registered
Joined
·
9 Posts
my 03 had some noise in the rear. check if its there when you go in a tight circle with your window down. if you do your rearend is probably going out. they had to replace mine. of course on warrenty. it had very little fluid in it.
 

·
Registered
Joined
·
178 Posts
Funny. I was just about about to post the same question when I saw this one. Thanks Guys, you may have saved me some time on my few days off.
 
1 - 8 of 8 Posts
Status
Not open for further replies.
Top