DodgeTalk Forum banner

Status
Not open for further replies.
1 - 12 of 12 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
I just bought a 2006 Dodge RAM 1500 4.7 liter. Cruising along at 50-55 mph and the brake warning light and the ABS come on and the chime comes on. It only stays on for a few seconds. Any idea why this might happen.

Thanks....
 

·
V10
Joined
·
628 Posts
how many miles?

the light goes back off?

could just be dirt, also your pads could be worn

someone else will know more
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
Just under 50K miles. The lights are only on for a few seconds, then they go out. Also, I noticed the speedometer fluctuates when it happens even though the speed of the truck does not change.
 

·
Registered
Joined
·
660 Posts
I don't know your set-up. But on my 03. I have 4 wheel ABS. The front hub bearings have the ABS sensers in them. I know that shorted wiring or bad senser will cause the break light and ABS light to be on simultaneously.
 

·
Registered
Joined
·
58 Posts
This happened to me on my '07, and it ended up being the speed sensors and abs sensors.
 

·
The Walt-n-ator
Joined
·
2,491 Posts
Your brake fluid may be low. Mine did the same thing when the fluid was low; as the brake pads wear, it takes more fluid to clamp the rotors. When my ABS sensor went bad, I got a DTC and not an ABS code. I hope this helps!
 

·
Registered
Joined
·
10 Posts
I have an 06 quad cab 4x4 laramie that did this. It started intermittently, then the lights stayed on all the time. They had to replace the sensors and the wheel hub.
 

·
greggram783
Joined
·
29 Posts
the same thing happend with my truck turned out that diff broke and the c clips broke and took out the speed sensor in the diff.
 

·
Registered
Joined
·
7 Posts
I would say that your speed sensor is going and not the abs sensors since your speedo is fluctuating when the lights come on.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #10
The speedo eventually quit working altogether. brake light came on, ABS light came on, speedo stopped working and check engine light came on. Eventually, the speedo starting working and brake/ABS lights went out. After a few starts the check engine light went out. I already replaced the rear diff speed sensor during the time the speedo was out and it made no difference. I'm going to bring to the dealer unless someone thinks it may be a simple problem.
 
1 - 12 of 12 Posts
Status
Not open for further replies.
Top