DodgeTalk Forum banner

Status
Not open for further replies.
1 - 1 of 1 Posts

·
Registered
Joined
·
43 Posts
Discussion Starter · #1 ·
So for a while (posted about it previously) I had a dropping oil pressure problem at idle after the engine warmed. Eventually I heard a loud clacking sound like someone tapping from inside the motor. After a while it got louder and stayed with the motor through the entire RPM band. So I said to myself obviously something is wrong and ironically engine treatments made it worse. So I took the motor apart and found almost all the parts have a think layer of dark red/brown and even black oil on them - with the exception of one of the cylindar heads (the one with the valve cover that has the oil cap). After taking everthing off of the block I realized I couldnt get two of the lifters out at all and am still struggling with them - Im assuming thats what the noise was. I decided to replace the lifters, cam, rockers, pushrods, timing chain and sprockets, valves and valve springs, headers (for fun since they came off anyways), and oil pump and driveshaft - all with hardened and reinforced parts and a more agressive cam. I had a machine shop that builds racing motors test and clean the heads and they told me I should do the valves and such but the good news was that the heads are in good shape (the motor has 100k miles). Anyways here are some pictures of the internals - any feedback would be much appreciated, thanks guys.









 
1 - 1 of 1 Posts
Status
Not open for further replies.
Top