DodgeTalk Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
Hey everyone I drive a 2011 ram 1500 4wd 5.7. So my alternator bearing started whining bad then once I shut the truck off the battery was dead and wasn’t being charged. So I went and bought an alternator put it in started the truck sounded perfect whining gone drive it to the gas station and came back home. ( didn’t drive but maybe 10 minutes). Parked the truck tried starting it again to see if the battery charged any and it tried starting sounded like a low battery so figured I didn’t drive long enough so I tried jumping it and I’m getting nothing lights in truck are on check engine is flashing and it won’t even try to turn over no clicking no nothing. Radio work lights I can hear fuel pump etc. tried putting in Netural nothing took the battery out tested it 12.6 volts it’s good but truck don’t even try to start or turn over. I’m stumped any help or thoughts.
 

·
Registered
Joined
·
5 Posts
Battery voltage is one thing. cranking amps is another. Did you end up replacing the battery?
A good rule of thumb on replacing the alternator is always to have a fully charged, if not new battery put in when you replace the alternator.
 

·
Registered
Joined
·
2 Posts
Its probably the battery being low first of then 2nd burnt the new Altnater by jumping it off with another car . i do know some new cars and trucks cant be jumped or jumping others off from dead batterys it could mess urs chargin system up . i would put a fully charged battery in and try it before anything . if not go get a new battery.
 
1 - 5 of 5 Posts
Top