DodgeTalk Forum banner

Status
Not open for further replies.
1 - 10 of 10 Posts

·
Registered
Joined
·
330 Posts
Discussion Starter #1
:ugh Well my altenator went out yesterday. I can't get it fixed until next wednesday( unemployment) Autozone, advanced both want 159.99 for the 160amp alt. and 169.99 for the 136amp alt. I think I will go with the 160amp alt.:) I have been wanting one anyway. Just thought I would post this.
Thanks
 

·
Registered
Joined
·
330 Posts
Discussion Starter #3
The belt is fine. just the Altenator. I almost didn't make it home yesterday. A check gauges, brake light, seatbelt light came on. I'm glad I made it home.
 

·
Registered
Joined
·
1,170 Posts
Man that sucks!! Sorry to hear that! Hope you get everything back to working order!
 

·
Registered
Joined
·
615 Posts
did you get the ALT checked? sometimes the pcm will cause a no charge situation just saying befor you spend some money you don't have. Good luck
 

·
Registered
Joined
·
330 Posts
Discussion Starter #7
I called around to see if a shop could rebuild it and nope they don't want to do it. Something about the slip ring and bushing? Anyway, I'm going to call some junkyards and see if they have one. I don't really like to get one from a junkyard but I want to find out anyway. To try and save some money. The alt gauge has been reading 0. for a couple of days. And I'm sure it's the Altenator. Thanks for your replys.
 

·
GetALittleMudOnTheTires
Joined
·
8,389 Posts

·
Registered
Joined
·
439 Posts
sorry to hear, where in Texas are you ?
 
1 - 10 of 10 Posts
Status
Not open for further replies.
Top