DodgeTalk Forum banner
Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter · #1 ·
Hey guys,
Just installed a tripple gauge pod on the pillar. Everything went great except there were no intructions on where to put the tranny sensor. Any one know of some site with instructions or just let me know what you did. Thanks.
1999 CTD auto tranny :help:
 

·
Registered
Joined
·
21 Posts
Assuming an Automatic, it is on the passenger side toward the front of the transmission on the govenor housing (just back of the dipstick tube. It is a 7/16" headed plug.
On Manual, you have to remove the PTO cover and drill and tap for the sensor. You will lose all the oil so be ready.
 

·
Registered
Joined
·
740 Posts
There is a test port on the 47re that you can use. You need a reducer (I have it if you are interested you can have it). I tried the port & it didn't work to well for me. So I bought a B&M drain plug kit for the pan & screwed it in in place of the plug. Works good & cheap too. BTW, how loud is your straight pipe & how do you like your Edge Attitude.
 

·
Registered
Joined
·
32 Posts
Discussion Starter · #4 ·
Thanks for the info I will be looking at it this weekend and hopefully all will go well. I just realized I posted it as a transmission pressure instead of a temperture sensor...I also just got in a banks big head waste gate dump. they claim it will add about 7lbs of boost, currently I am topped out at 24.5lbs. The exhaust is killer, my buddy borrowed the truck last week and I could hear him from 4 blocks away :rck: I am getting ready to go 4" turbo back straight piped.
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top