DodgeTalk Forum banner

Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi I have an 08 ram 5.7 4x4. While out today driving in 4 wheel drive something made a "clunk" and now no 4x4. It's electronic shift which sounds like it's working. The lights on the dash come on like normal and no serv 4x4 light. It's almost like the front driveshaft broke inside the transfer case. You can turn it by hand is that normal? Truck on the ground in park. When you drive it it makes a "rattle" type sound. Any Ideas? I'm no mechanic and the truck is going in monday but it is just bugging me.

Thanks in advance for any help
 

·
MADBRAD
Joined
·
1,155 Posts
Interesting. Ive had a few issues with mine as well. When you shift into 4WD the electric shift motor shifts the transfer case and an electric actuator locks your front axles together. I doubt the transfer case is the issue. Sounds like something with your front driveshaft or the actuator mounted on your front axle.
 

·
Registered
Joined
·
878 Posts
If you can turn the front driveshaft by hand when the truck is in park on the ground sounds like some teeth are missing somewhere. More than likely in the front ring/pinion, i see it's an 08 hopefully still under warrenty.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
Hi just an update. This all happened last saturday. On sunday i crawled under for a better look. I found the CV joint on the passenger side was blown apart. I got really lucky that was all that it was. Realitivly cheap fix as i have no warranty left on the truck.
And the front driveshaft turning by hand is normal.
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top