DodgeTalk Forum banner

Status
Not open for further replies.
1 - 11 of 11 Posts

·
Registered
Joined
·
92 Posts
Discussion Starter #1
Hey all, I own a 2001.5 2500 4x4 5.9l (gas), 157,000 just bought it a year ago and been a helleva great truck, no problems what so ever till now. It seems like anywhere over 50 in OD the truck slips out of lock up and back again. Like a rpm surge. Iv been looking up other members problems with the rpm surge but cant find the exact issue as mine. i went to advanced auto and bought a new tps. Installed it and seems to do the trick for a couple days. Then it came back again then bought another one thinking the new one was bad. Same problem, then bought 2 at a local junk yard installed them and it seems better but not 100%. i dont know what else to look for i hope its nothing in the trans. And btw when the truck goes into OD its a harsh shift likes shakes the whole truck. If you guys can help that would be great. Thanks :gr_patrio
 

·
Registered
Joined
·
92 Posts
Discussion Starter #2
anyone!?
 

·
Registered
Joined
·
584 Posts
Did you reset the computer? It probably didn't set a code but resetting the computer seems to make these things work. As for the hard shift it cold be one of several things that may cause it. Others may chime in here with some advice and ideas as to the hard shift.
 

·
Transmission Man!
Joined
·
3,508 Posts
Make sure the brake switch is not the problem. (out of adjustment)
 

·
Registered
Joined
·
92 Posts
Discussion Starter #5
i pulled the pos + terminal when i did the tps. and how do i go about checking the break switch? thanks guys
 

·
Transmission Man!
Joined
·
3,508 Posts
You want to make sure that you have plenty of pedal movement before the brake lights come on. If you barely touch/move the brake pedal and the brake lights come on,that is probably the problem. Some times you have to bend the bracket that the switch is on to correct it. I have seen it on a couple of customers trucks now.
 

·
Registered
Joined
·
92 Posts
Discussion Starter #7
thanks for the info. i tryed that and it did nothing. i hope its not the trans.
 

·
Registered
Joined
·
60 Posts
Your OD bands/clutches are probably worn.

I'd get it rebuilt now, rather than later.
 

·
Registered
Joined
·
92 Posts
Discussion Starter #9
how mutch in cost you think?
 

·
Registered
Joined
·
92 Posts
Discussion Starter #10
sorry for the double post but this morning on my way to work i noticed the truck surging espcially going up hill the most pulling my land scaping trailer. so prob the tourqu converter?
 

·
Woodstock
Joined
·
762 Posts
1 - 11 of 11 Posts
Status
Not open for further replies.
Top