DodgeTalk Forum banner

Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter · #1 ·
I just had my tranny rebuilt and the trans shop said that my B&M supercooler was not as good as the haden they suggested I replace it with. WELL today I put a sunaco electric oil temp guage on the truck (sensor in pan drain plug) after running the beltway to the river about 35 miles of 70mph the gauge was reading 210, damn thats hot??? when i got back i did a little research online, this haden cooler is $30 @ Orielly, and the B&M is only avaliable at the local speed shops for about $85?? get what ya pay for? I had the trans guys put the B&M in the back of truck (good thing) I decided to replace the haden with the B&M just to see what the temp differences were. took same trip same speed (actually at the hottest point of the day 95 deg) never got over 180, hum?? i kinda figured that was kinda hot too, so OVERKILL hit me. I'll move the stock cooler from behind the condenser to the front and hook it inline with the B&M. took same trip same speed. never went over 170 or so? see pics
1st hayden only @ 210
2nd B&M with stock @ 170 ?
didnt take pic of gauge with B&M only it was just before 180
3rd is the size comparisons
 

Attachments

·
Registered
Joined
·
868 Posts
I have a B&M #24,000 GVW plate style on my Concorde and am very happy with it. I have not run a temp guage to see what it is holding though. It is in series with the stock cooler. It so far has helped to allow me another 30,000 mi on a tranny that I had left for junk. Seafoam helped it too, but now I have upgraded to ATF 4 in leu of ATF 3 with Seafoam.
Thanks for performing this test. Too bad your tranny shop didn't do the same.
 

·
******* SPACESTATION
Joined
·
5,543 Posts
I have a hayden HD tranny cooler right behind the grill, with 10" electric fan mounted onto it, my tranny temp never gets over 180, even when towing around town.
I plumbed mine from the stock cooler to the hayden then back to the tranny.
Looks to be about the same size as yours, maybe 1 or 2 more passes.
I think your problem was probably the fact that it was drawing hot air from the radiator & condensor.
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top