DodgeTalk Forum banner

Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have a 05 dodge Dakota quad cab 4x4 with 4.7. I've been have transmission problems for the last few weeks. Here's a list of my symptoms and hopfully someone can help.

1. When I first start my truck reverse seems fine but when I shift from reverse to drive the truck jumps forward.

2. Every great once in a while when I stop at s stop sign the truck bogs down and dies

3. After coming to a complete stop I can tell something is slipping because it takes more Rpms to get rolling again

4. The TC isn't locking up at highway speeds for the rpm to settle at 1500 while cruising.

5. All gears shift smoothly and I've tried putting the gearshift into 1st gear when leaving from fully stopped and still the Rpms are higher than normal to start moving.

6. Transmission over heat light seems to come on at random times and go off after a few sec or at least when I kill the truck and restart the light stays off

7. There's only been one time that this has happened but still might help diagnose. Was coming from a dead stop trying to go up a small incline onto the highway and the truck barely made it up. After on the road the truck very slowly came up to speed so I put the gas pedal all the way down and nothing happened. Speed slowly went up and the Rpms didn't hardly raise at all. So I pulled over killed the truck and restarted. Truck ran great with no hesitation at all. Actually the truck ran great for 2 days and now it's back to messing up

Do you thing it's a solenoid, torque converter or my transmission going out?
 

·
BamaTech
Joined
·
41 Posts
My 2006 is doing almost the same thing transmission heat light came on and off at random , light hasnt come on in at least a month but it has NO power when taking off or going up hill , you can floor it and it will rev out of the frame but truck just slowly gets moving . No Torque at all .
 

·
BamaTech
Joined
·
41 Posts
Torque Converter

I have replaced the Torque Converter and fixed the Terrible gas mileage and no power issue . When you replace it or have it replaced , make sure to replace all filters spin on and sump filter , new fluid around 14 qts atf4 , and NUMBER 1 thing MOST IMPORTANT flush the cooler and lines very good before running it with new converter .
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top