DodgeTalk Forum banner
Status
Not open for further replies.
1 - 11 of 11 Posts

·
Jason
Joined
·
3,866 Posts
Discussion Starter · #1 ·
About a mile from home the check gauges light came on. The water temp was at about 3/4. I turned the heat on but it was just blowing cold air. Then the temp pegged out. There was a boom and coolant sprayed on the windshield. Found that the hose had separated at the cap. Could it be the thermostat failed to open causing enough pressure to blow the hose apart? I have'nt noticed any coolant leaks. I had replaced the thermostat about 6 months ago with a 160 degree one. I plan on flushing the system, and replacing the stat and hose. Thanks in advance.
 

·
Registered
Joined
·
545 Posts
160 degrees? That is kinda low for the D. I know many say that the optimal temp for the D is 180 degress but I don't think that would by your problem....

What you say sounds logical... but that would have been ALOT of pressure!! Good luck and Hope you get it working.....
 

·
Jason
Joined
·
3,866 Posts
Discussion Starter · #3 ·
Yeah, I put it in right before going to Myrtle Beach in july for vacation. Figured it might make the A/C cooler and the motor while sittin in traffic.
 

·
Registered
Joined
·
545 Posts
RTDurango said:
....after it cooled down of course.

Oh come on... you don't need it cool down.... HEHE.... I have given myself very severe burns because of stupidity :)
 

·
Keystoner
Joined
·
5,534 Posts
I bet that scared the crap outcha....... I've had mine slip off, but not explode
 

·
Registered
Joined
·
4,953 Posts
I'm still fond of my WOT freeze plug catastrophe @ 90 MPH.
 

·
Registered
Joined
·
4,953 Posts
OH! Also, make sure you rinse things down under the hood a bit, and use a corrosion inhibitor like Boeshield or CRC, to drive the moisture out of relays, PCM connections, etc...
 

·
Jason
Joined
·
3,866 Posts
Discussion Starter · #9 ·
rockadaous said:
I bet that scared the crap outcha....... I've had mine slip off, but not explode
Yeah, if coolant had'nt sprayed on the windshield I would have pulled over. It was loud. Also, this happened at 11pm and the temp was 45F outside.


RTDURANGO said:
the fuel air mixture has to be affecting your mileage i would guess.

It must be, the overhead computer says 11.5 mpg

So, you think it was the t-stat not opening that blowed the hose? or is that possible to create that much pressure by itself? Thanks guys!
 

·
Registered
Joined
·
750 Posts
Hey all, I just had this happen to me, hose completely came off right below the radiator cap. The hose won't stay back on. Any suggestions or tips or advice?
 

·
Jason
Joined
·
3,866 Posts
Discussion Starter · #11 ·
1 - 11 of 11 Posts
Status
Not open for further replies.
Top