DodgeTalk Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have a 2006 dakota slt quad cab 4x4 4.7L magnum with 128000 miles on it.Last night I pulled into a parking spot when I tried to put it into park from drive the gear shifter would not go up so I pulled shifter down into first which it went down fine but now it's stuck in the 1st gear spot. I had to disconnect the battery to get shifter to come up so I could remove my keys I tried to see if it would go into park this morning but the gear shifter just go up and down now and will not engage the Transmission. My fluid level is good there's no check engine light on and there was no warning of a problem any help would be appreciated.
Thank you in advance
 

·
Registered
Joined
·
781 Posts
Sounds like the cable snapped. The cable is reasonably priced, but the labor will kill you. Cost of the cable was about $50 in 2011 (when this happened to me).

On my '06 Ram 1500 I had something similar happen about 10 years ago. After arriving at my son's game I went to put in in Park and had to jiggle the lever to do so. It had never done that before. I kept playing with it and when I pulled all the way to 1st the cable snapped. Ended up towing it to the dealer.

Dealer found the cable had indeed snapped, but what had caused the original issue was a check ball inside the transmission had become displaced. Cost was around $575 total. Tech found the cable broken and the interior linkage broken - I believe there was a check ball that came off (new one held by a cotter pin). Since they had to drop the pan, I ended up with new transmission filters and fresh fluid (basically a transmission service) as well as a new cable and interior linkage. That was at 125K miles. Truck now has 272K miles and no problems with the linkage and cable since.
 
1 - 2 of 2 Posts
Top