DodgeTalk Forum banner

Status
Not open for further replies.
1 - 9 of 9 Posts

·
Registered
Joined
·
183 Posts
Discussion Starter #1
This is a strange one. The selector for where the blower is directed will only blow on the defrost no matter where the selector is. Has anyone ever seen of heard of this?I'm going knuckin futs trying to figure this one out.
 

·
Registered
Joined
·
76 Posts
It's either your control head going south or one of the actuators that moves the direction of the air through the air box. I don't know how to tell you wich one, but those are the only two thing I know of that would make it so that.
 

·
Todd O
Joined
·
933 Posts
If it has a vacuum actuator for the blend doors I would check that. If it's electrically operated I would check the motor for the doors. I have an 02 and I don't know how the doors are operated but I think it is electrical. Check your climate control and make sure nothing is loose there if that's not the problem your just going to have to do some electrical troubleshooting YEAH! LOL
 

·
Registered
Joined
·
827 Posts
check out the simple stuff first.........should be vacuum operated..........my bet is that the vacuum line from the manifold to the hvac unit is broken or leaking............the ussual place is as it passes through the firewall..........just open the hood and look.............small plastic hose runs from somewhere on the manifold through the firewall to the heater control head..ussually break under the hood.............defrost is the default setting if no vacuum is applied......good luck....
 

·
Registered
Joined
·
286 Posts
I Have The Same Problem. Where Is The Blend Dorr Actuator? I Just Got This Durango On 12/24.
 

·
Registered
Joined
·
183 Posts
Discussion Starter #7
Thanks for the input. I have checked the plugs at the controls and they are good.My next thing to check is going to be the vacuum line(duh me,didn't think it had one).I will keep it updated.
 

·
Registered
Joined
·
286 Posts
I Was Under My Dash Today And Noticed That The Blower Box??? Is Not Conected To The Air Routing System. Anyone Seen This? Also Next To The Blend Door Actuator Is A Black Vac. Line With A Bracket That Is Not Conected To Anything. Is That Normal? Thanks,vinnie
 
1 - 9 of 9 Posts
Status
Not open for further replies.
Top