DodgeTalk Forum banner
Status
Not open for further replies.
1 - 20 of 47 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter · #1 ·
alright, well iv searched and search, and am getting fed up, im installing an aftermarket deck, i got the wiring harness and what not, now the trucks wiring harness and the kit i got dont completely match up, the constant power matches, and the speakers, other than that nothing else matches. i got my test light out, and the trucks harness has no switched 12V. which makes no sense to me, how does the factory deck know when to turn on? wireless? :huh: . so to sum it up, i have 2 constant powers(key on or off), 2 grounds(not sure why), speakers do work, and two other connectors i have no idea what they are...... no dimming wire. so, if anyone can help me on what the hell is going on here, id really be happy. thanks in advance :help:
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #3 ·
that helps to a point, it says switched power, and then wire color is data. what does this mean? i have to buy something else just to get switched? dont mind me, im just getting mad, never had this problem before, and its getting to me....
 

·
Registered
Joined
·
119 Posts
You have to run a wire to a 12v in the fuse box so it knows when to turn off and on, i did this for my naviagation. Pick something like the cig lighter or something. If this is what your talking about. Accessory switch.
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #6 ·
ok, now iv got a better idea of whats goin on in there. right now i switched 2 pins, i cut the loop that did power from 1 to 11, and i moved the switched lead over to the constant power, which now means it stays on and i have to remember to turn it off. what i think i will do is when i get my remote start installed, what il have them do is usually there is a switched wire that i can relay, and run to the deck, so when i turn on the alarm, it will cut power to the switched lead. because with the job i have, im constantly driving, then shutting off the truck and sitting for a while, then driving again, so it shuts the radio on and off alot. so i really do thank you guys for your help, and i will be saving those so i have them for future refrence. thanks again guys...
 

·
Yea, It's a Hemi
Joined
·
6,864 Posts
You need the manual to the aftermarket deck... you read which wire is which on the deck harness, and match it up to the trucks wire harness (the additional harness purchased). It should tell you whats what on the new truck harness. Thats what I did, purples matched up but I think the greens do not match up. Remember, there will be at least 2 wires not used.
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #8 ·
no i got all that, dont worrie about that, what im saying is the wire harness that i bought to plug in to the truck, it had switched power at pin 2, and dimming at pin 12, which are both empty. thats what threw me off. iv installed plenty of decks, including my dads laser where the harnesses didnt match and i ended up moving every pin in the harness to the correct location. now that sucked.....

its just missing switched power and dimming that pissed me off. i dont understand how they make that work on the stock deck, but what ever....
 

·
Yea, It's a Hemi
Joined
·
6,864 Posts
Hmm I dont know.. maybe tap into the stock power wire and run a new wire to the new harness? I have never been able to use the dimmer... sucks at nite sometimes lol
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #10 ·
yah, pin 1 and 11 are both canstant power, so im using both, one for constant, and one for switched(which is now constant). so the deck works, just doesnt turn off when i turn the key off......
 

·
Yea, It's a Hemi
Joined
·
6,864 Posts
So you didnt hook the ACC wire up? The harness on the truck has ACC on the wire and the deck should have it in the manual.
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #12 ·
ok, i think your not understanding or something, if you scroll up and look at the pic that jaredR posted, it shows my trucks harness, the one that used to plug in to the factory deck, now if you read which pin is what, 1 and 12 are constant power, then 11 and 22 are both ground, then you have speakers, and two others that dont do a damn thing. now, on the harness i bought to go from that to my decks harness, 1 and 12 are constant power with a loop between them, then 2 is switched, which doesnt exist on my truck, so what i did, is i got rid of the loop from 1 to 12, and made 12 my conection from my switched to its constant power, so when all is said and done, the deck works, just wont shut off when i take the key out, i have to turn it off, which is fine till i get a remote start put in...
 

·
Registered
Joined
·
251 Posts
Power Wire

Run your constant to the pink/green stripe wire that goes into the cig lighter and hook your ACC wire up to stock harness and you will be good to go. I had to call Crutchfield when I installed my aftermarket head unit.
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #15 ·
ok, i dont have an issue anymore, and iv said this like 5 times, THERE IS NO ACC(SWITCHED). i dont know where you guys think there is, for switched id have to tap in to cig lighter like some said, and im not going too, so dont worrie about it guys. thanks to the people that actually understand whats going on with my truck(the ones that looked at the pics, and see i have no acc wire).......................................
 

·
Yea, It's a Hemi
Joined
·
6,864 Posts
DRamSLT1500 said:
ok, i dont have an issue anymore, and iv said this like 5 times, THERE IS NO ACC(SWITCHED). i dont know where you guys think there is, for switched id have to tap in to cig lighter like some said, and im not going too, so dont worrie about it guys. thanks to the people that actually understand whats going on with my truck(the ones that looked at the pics, and see i have no acc wire).......................................
Well... just for your info there is always an ACC wire. No matter what it is. You just want to be selfish and not listen to good advice. As some said tap it into the cigarrete lighter.. not to hard to do and wont be seen. There is an ACC for your trucks harness also, I believe Red is 12 volt and Yellow is ACC...
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #17 ·
ok, stop acting like you know, scroll up and look at the pic, there is no acc wire in the trucks harness, other people have even said that there isnt, and that you have to tap the cig lighter or something else to get switched power, i dont see how you think you know when other people are saying that there isnt one, you must have a different year, and assume that they are the same setup, and they ARE NOT. now, if you can even understand what i am saying, maybe you will open your eyes, and look. till then, stop posting in a thread that you have no idea how to help......
 

·
Registered
Joined
·
23,004 Posts
DRamSLT1500 said:
i got my test light out, and the trucks harness has no switched 12V. which makes no sense to me, how does the factory deck know when to turn on? wireless? :huh:
You have an 06, these and the 07's receive their "Power On" from the pci bus. So essentially they are told when to turn on/off by trucks computer. You can buy the correct harness for this moel and your problems are solved.

KB
 

·
Registered
Joined
·
23,004 Posts
DRamSLT1500 said:
ok, stop acting like you know, scroll up and look at the pic, there is no acc wire in the trucks harness, other people have even said that there isnt, and that you have to tap the cig lighter or something else to get switched power, i dont see how you think you know when other people are saying that there isnt one, you must have a different year, and assume that they are the same setup, and they ARE NOT. now, if you can even understand what i am saying, maybe you will open your eyes, and look. till then, stop posting in a thread that you have no idea how to help......
Settle down, acting like this especially as a newb, is a quick and easy way to be shown the door. If you searched for this info in the audio forum, it's likely you would have found your answer. Hope you enjoy your time here at DT, we're all here to help ech other out and have a little fun. :tup:

KB
 

·
I pickle they.
Joined
·
737 Posts
If yours is an 06, and i guess an 07, you need to find power for the aftermarket unit, or buy one of the new harnesses out.

I have an 06.

I spliced into the pink/yellow striped wire under the dash, next to the pedals.

No problems, no dummy lights popping up from this.
 
1 - 20 of 47 Posts
Status
Not open for further replies.
Top