DodgeTalk Forum banner

Status
Not open for further replies.
221 - 240 of 553 Posts

·
voo doo 1 I am buggin out
Joined
·
6,355 Posts
Discussion Starter #221
I want to solve the 06 Dilema as much as you do ... so hopefully someone with an 06 that really wants the switches will check to see if they have the +5 vdc at the cluster or if they want some help bring it to my house and I will verify ;) but you would have to drive to Saint Cloud Florida
 

·
Registered
Joined
·
294 Posts
welp I have mine all wired up, and I didnt get a +5V reading at all, when i connectoed to the "stated" +5V clockspring,and to a ground. I got a non reading with the steering wheel set to ACC

not sure if this was the right way or not

let me know what readings you need me to take
 

·
voo doo 1 I am buggin out
Joined
·
6,355 Posts
Discussion Starter #223
titanconvert said:
welp I have mine all wired up, and I didnt get a +5V reading at all, when i connectoed to the "stated" +5V clockspring,and to a ground. I got a non reading with the steering wheel set to ACC

not sure if this was the right way or not

let me know what readings you need me to take
you should be getting the +5 volts from the back of the cluster first ..... even if you ran the wire from the cluster to the clock spring you may not get the voltage if the wire isnt seated all the way in the cluster (how I know this is cause when I did mine thats were my problem started from .. no voltage until I reseated the wire in the cluster) ...... that will be your starting point for the voltage but you need to make sure you are on a proper ground. After you have your +5 volts there then you can check the back of the clock spring with your added ground wire and then it should be golden. Let me know what ya find out .... I would love to help you 06 Guys solve this just some of the other guys as well
 

·
Registered
Joined
·
32 Posts
I know on my 06 I am getting the voltage and I can manipulate that voltage with the switches, just as it should. I verified the voltages on the rear of the clockspring going to the cluster. Something in the cluster is not taking the voltage and putting it on the can-bus to the radio (I think). Everything seems to be doing as it should, just the can-bus is not doing its part. I believe it is something in the cluster that puts it on the bus, I just dont know how or what at that point.
 

·
2014 1500 4x4 Laramie CC
Joined
·
431 Posts
Did anyone every successfully get this working in an 06? I just bought a few parts to do it, and am getting ready to try. I have the adapter and harness for my Kenwood deck, and then another adapter which is specifically for the 06 Dodge with CAN Bus, and allows the CAN bus to interoperate with the other adapter. Are you guys using this CAN Bus adapter?

Thanks,
Daren
 

·
Registered
Joined
·
70 Posts
I have an 07 ram and just bought the upgrade 6disc changer stereo to install in the place of the stock cd unit. Has anyone had any success installing the steering controls for the upgrade unit? Is there a chance it will work? I know this thread is old. I was hoping to get the information without creating a new thread.
 

·
Registered
Joined
·
32 Posts
I have not been able to find a way on my 06. I am just keeping my ears open at this point hoping to come across something that may lead me in the right direction. Keep us posted if you have success.
 

·
Registered
Joined
·
48 Posts
Hello everyone
Have you heard if this will work on a 03???? my wheel looks a little different than the one in the pictures
thx for the numbers and pictures.

Dodgetalk rules :rck:
 

·
voo doo 1 I am buggin out
Joined
·
6,355 Posts
Discussion Starter #230
janlov said:
Hello everyone
Have you heard if this will work on a 03???? my wheel looks a little different than the one in the pictures
thx for the numbers and pictures.

Dodgetalk rules :rck:
Yes this will work on an 03 .... not sure why it would be a diffrent steering wheel.
the wiring color maybe slightly diffrent but the concept and install will be the same as my 04
 

·
Registered
Joined
·
3 Posts
I have never posted on here before........but i read this lot...
this tread on radio controls is great.......i ordered the parts
on line from .makeitmopar. .....i got the harness
56000918ac for 32.33 not the 56042934aa for 150.00
it worked perfect ......very good instructions only took
a couple hours.........thanks for all the great info
 

·
voo doo 1 I am buggin out
Joined
·
6,355 Posts
Discussion Starter #232
mgr003 said:
I have never posted on here before........but i read this lot...
this tread on radio controls is great.......i ordered the parts
on line from .makeitmopar. .....i got the harness
56000918ac for 32.33 not the 56042934aa for 150.00
it worked perfect ......very good instructions only took
a couple hours.........thanks for all the great info
First post too ... Welcome to Dodgetalk and glad this thread has helped you in your quest for radio controls ... that was my mission when I posted this thread ... to help others get er done:rck:
 

·
Registered
Joined
·
256 Posts
mgr003 said:
I have never posted on here before........but i read this lot...
this tread on radio controls is great.......i ordered the parts
on line from .makeitmopar. .....i got the harness
56000918ac for 32.33 not the 56042934aa for 150.00
it worked perfect ......very good instructions only took
a couple hours.........thanks for all the great info
The 56000918AC harness works GREAT! I used it when my brother traded in his chevy for a DODGE. I wished I'd known about that harness when I did mine. i mean, mine works fine, but if you take off the airbag, you can tell that it was a homemade job. Congrats on your success! That's what is so great about this entire site. It ROCKS!!
 

·
Registered
Joined
·
22 Posts
Need help

I wired in the radio controls using the 56000918AC harness, and it doesn't work. Rechecked all my connections, and I think the problem is the connector on C2 pin 12. I don't think the connector left over from the harness is the right one. Has anyone tried using the leftover parts from the 56000918AC harness? My 04 2500 doesn't have the infinity setup, so I had to run the wire from the clockspring to C2 pin 12.

Maybe someone has some leftover parts they are willing to sell me? I don't want to have to purchase an entire harness 56042934AA unless I have to.
 

·
voo doo 1 I am buggin out
Joined
·
6,355 Posts
Discussion Starter #235
kryten98371 said:
I wired in the radio controls using the 56000918AC harness, and it doesn't work. Rechecked all my connections, and I think the problem is the connector on C2 pin 12. I don't think the connector left over from the harness is the right one. Has anyone tried using the leftover parts from the 56000918AC harness? My 04 2500 doesn't have the infinity setup, so I had to run the wire from the clockspring to C2 pin 12.

Maybe someone has some leftover parts they are willing to sell me? I don't want to have to purchase an entire harness 56042934AA unless I have to.
post a pic if the piece you need or send me a pm on what piece you need, I have some left over gold connectors .... sending a pm as well
 

·
Registered
Joined
·
22 Posts
Late last night, in the dark and rain (it ALWAYS rains here in the Seattle area), I finally got it to work. The leftover parts from the 56000918AC harness worked fine in the clockspring connector, but the connector for the C2 harness on the back of the instrument cluster was not quite the right part. After a couple of tries, the connector seated, and the controls now work. I talked to sherdep on the phone about getting the proper pin for the C2 connector.

I consider this mod a safety issue. I'll be pulling an RV on a long trip soon, and not having to reach over to adjust the radio/navigaition system will make the road safer for all!

My setup now includes:
RB1
IPOD adapter
Sirius
6-Disk changer

All controlled by the steering wheel radio controls.

I posted in the forum last year on how to make a custom cable to connect the mux to the 6-disk changer, if anyone is interested.
 

·
voo doo 1 I am buggin out
Joined
·
6,355 Posts
Discussion Starter #238
offroadgenius06 said:
god durn man nice job looks like alotta work im glade my 03 came with them lol!!!!!!
Looks like alot of work but I think it is a well worth mod IMO.:D
My 01 had the switches but my 04 didnt so when I had seen some others doing this MOD I decided to make a How To thread with as much detail as possible to make it easier on any body that wanted to try this mod.:rck:
 

·
Registered MOPAR User
Joined
·
9,350 Posts
This is nice, looks like a new mod for my 04 soon. Can I swap out the stearing wheel from my 99 rango that has the controls, all I would need is the harness. J/K
 

·
Registered
Joined
·
22 Posts
I purchased an 04 steering wheel that has the cutouts. I bought it off of eBay just in case I screwed up cutting my wheel. The wheel is black (or very dark gray). PM me if interested.

Mark
 
221 - 240 of 553 Posts
Status
Not open for further replies.
Top