DodgeTalk Forum banner

Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
I rebuild the trans probably 8k miles ago and today while getting off the highway the durango doesn't want to shift. I get it down the street and park it in the driveway. I look underneath and while its running in drive im dumping tons of trans fluid. It looks like its coming from the converter area. The car will move under its own power but now it has problems shifting. I checked the trans fluid and its way over full but I don't remember filling it all that high. Any ideas what may have just happened?
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #2 ·
I would like to add that I replaced the filter and tranny fluid and filled it to the proper level and its leaking like crazy. "steady stream"... tranny still drives and shifts fine but its losing a LOT of fluid. Its coming from the bottom of the bellhousing and even after I shut it off it still is leaking from the puddling at the bottom of the bellhousing. Is this the pump or the converter???
 

·
Pimp On Sir Don
Joined
·
12,782 Posts
check to make sure it's not the line running up to the trans cooler in the radiator.
 

·
WORLD'S GREATEST TRUCK
Joined
·
4,435 Posts
Hey Rodrigues, I would stop driving it right away until you get the leak fixed. Good Luck.
 

·
Registered
Joined
·
827 Posts
could be torque convertor or just a tranny front seal. you won't know till it till you get the trans out
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top