DodgeTalk Forum banner

Status
Not open for further replies.
1 - 20 of 73 Posts

·
HEMI_KY
Joined
·
186 Posts
Discussion Starter #1
Once right after starting. I was in reverse backing out, stopped, shifted to drive, and it died.

Second time was after coming to a complete stop on an exit ramp from the interstate.

Both times just shifted into neutral and started it back... But what the hell?? :mad:

Just had oil change, tranny fluid change, new belt, and idler pulleys.

:gr_patrio
 

·
DFWRAM
Joined
·
2,254 Posts
now my truck would do it if i hit the gas relly hard and then the brakes really fast <<<<<<<<<<<<< before my super chips

after it would do it in the cold after a hard pull and let off

i went and got the update from the SC web site and it still does it sometimes

but i can tell when it is about to si i jus give it some gas and it wont die:crazy:
 

·
Same Name, Different Game
Joined
·
9,640 Posts
My hemi did this to me a couple times before it sent an idiot light to the dash. Turned out I had carbon build up on the throttle body. I'd start there.
 

·
HEMI_KY
Joined
·
186 Posts
Discussion Starter #4
My hemi did this to me a couple times before it sent an idiot light to the dash. Turned out I had carbon build up on the throttle body. I'd start there.
So, how do I go about cleaning that up? Seafoam?

Sometimes I'll be accelerating and then all of the sudden it's like someone pushes a button that gives me more power for a brief moment, then it kicks back down...
 

·
Wilson
Joined
·
971 Posts
Mine ran kinda funky for a while before my cam shaft and crankshaft position sensor went out. Not as bad as yours though. Any codes?
 

·
Wilson
Joined
·
971 Posts
Hmmm????? Any performance mods to speak of. If so take it back to stock reset the PCM see if it helps. Did it run for a while right after dying or was it vroom,die,vroom,die?

I had a Ferd that when the TPS went out it would start then immediately die like you turned off the key.
 

·
Wilson
Joined
·
971 Posts
Here the how to on TB cleaning
http://www.dodgetalk.com/forums/showthread.php?t=166641

As far as sea foam use half the can it the brake booster (see pic) use the other half in gas tank. Let the booster line suck it in and shut your truck off for 10-15 then start it up. It'll run rough for a while sit back and watch the smoke show

vac hose.JPG
 

·
Same Name, Different Game
Joined
·
9,640 Posts
Thanks WDFOLEY- I would have never been able to answer how to clean the TB. Mine was covered under warranty.
 

·
DirtRunner TreeDragger
Joined
·
895 Posts
It may seem odd, but I wonder if your transmission filters were changed or cleaned, you didn't say, I had this problem with my transmission, just as you described your truck as doing. I flushed the tranny again, cleaned the filters, refilled, and have not had the problem again, {going on six mos now**.
 

·
They call me Radio
Joined
·
4,809 Posts
A dirty PCV valve has also been known to cause this. It's supposed to be replaced in your normal tuneups.
 

·
Registered
Joined
·
1,016 Posts
dont all hemi's stall?
i thought there was a huge thread on here
 

·
Registered
Joined
·
1,016 Posts
mine stalls once in a while.. but funny.. i changed trans fluid and filters in the summer when i put in the transgo kit.. hasnt done it since.. been close to a year now.
 

·
Registered
Joined
·
1,040 Posts
You can also buy TB spray... just remove your intake and spray it in with your truck running, spray it untill it almost stalls and then you can repeat. Just make sure that you take it for a run after to run it all through.
 

·
Registered
Joined
·
48 Posts
My truck is doing the same thing. My check engine light came up and the code said that its a bad ERG valve(?). What is it and how do i fix it?
 

·
Wilson
Joined
·
971 Posts
My truck is doing the same thing. My check engine light came up and the code said that its a bad ERG valve(?). What is it and how do i fix it?
I didn't think ours had EGR valves. What was the code?
 

·
Wilson
Joined
·
971 Posts
You can also buy TB spray... just remove your intake and spray it in with your truck running, spray it untill it almost stalls and then you can repeat. Just make sure that you take it for a run after to run it all through.
That will work for the throat and front of the butterfly but wont help for the carbon buildup on the backside of the butterfly and. Ive always found it best to take the TB all the way off. Only takes about 10-15 min to take it off. Not even a gasket to replace.
 

·
HEMI_KY
Joined
·
186 Posts
Discussion Starter #19
I didn't think ours had EGR valves. What was the code?
My EGR valve was replaced under warranty a couple of years ago.
 

·
HEMI_KY
Joined
·
186 Posts
Discussion Starter #20
Hmmm????? Any performance mods to speak of. If so take it back to stock reset the PCM see if it helps. Did it run for a while right after dying or was it vroom,die,vroom,die?
No performance mods unless you consider a drop-in Trueflow air filter and a Flowmaster muffler, but nothing computer wise.

I reset the PCM then drove the hell out of it. Hasn't done it since then.

As for how it died; it just died. No sputtering, choking, just dead with dash lights.
 
1 - 20 of 73 Posts
Status
Not open for further replies.
Top