DodgeTalk Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hey guys,
2016 2500 69,000 miles 6 speed man. full delete EFI live. I purchased it this way. Never could work the previous owners name out of the dealership to ask about tune. Doing a cabin addition at 6000 ft this spring. After truck sits for 5 hours or so when i would start it , blowing blue/white smoke and running terribly rough, more throttle the worse it got. Coming down off the mountain exhaust brake on still smoking. If you give it just enough peddle to stop the exhaust brake smokes like crazy like something from a bat man movie. In 3 miles or so it stops runs like a dream. Absolutely no symptoms at home that ive never saw. Start it every morning and now im watching it of course and nothing no smoke no rough idle. Took it to my trusted local mechanic, his first thought was a dripping nozzle that wasnt sealing up , pulled injectors sent them to bosch for testing. Nothing wrong with injectors but replaced tips anyway. No change , more testing determined that #1 or 5 cylinder is cause of smoke. He replaced one of them (i never asked which), adjusted my valves and said come get it and drive it, but i could tell he wasnt sure. Drove it for 3 weeks back to same job same exact scenario no apparent issues. Fixed finally. 2 months later same deal up steep driveway for a couple miles for countertop installation. Parked for 8 hours , fire it up running just fine no reason to think anything , using exhaust brake instead of foot brake , something catches my eye in the mirror , smoking like crazy. Now im working 4 miles from my house driveway is so steep 4 wheel drive is the only way to keep from spinning in the gravel. Work for 8 hours start it runs great no smoke no nothing, in 2 miles coming home smoking like crazy worse than before. As soon as you you touch the throttle to avoid exhaust brake its insane smoke. If you give it a tiny bit more throttle like to accelerate it quits smoking . At the bottom of the hill leaving stop sign and accelerating runs great no smoke absolutely nothing until the next day leaving work. Im at a total loss. No codes no nothing. Having great luck lately Toyota just lost the head gasket so as soon as i get it back the diesel goes in, but throwing $$ at it is getting expensive. Just looking for recommendations or something to look at ?, look for? Anyone?
Thank you
 

·
Registered
Joined
·
3 Posts
All I can add is,
Blue smoke = oil
White smoke = water/coolant

Mentioned dealing with a head gasket on another vehicle, is it safe to assume you checked your oil and coolant levels in the ram, and looked for cross contamination?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
All I can add is,
Blue smoke = oil
White smoke = water/coolant

Mentioned dealing with a head gasket on another vehicle, is it safe to assume you checked your oil and coolant levels in the ram, and looked for cross contamination?


Sent from my iPhone using Tapatalk
Yes sir,
All of that has been checked that was my first fear when I noticed it. It’s more blue than anything but still odd. My mechanic had it for a month scratching his head trying to figure it out.
thank you for the reply
 

·
Beware the Underbite!!!
Joined
·
6,704 Posts
its either overfueling or has a stuck injector. blue smoke on a diesel tends to be major fuel loading. its blueish white. I would look into the injection pump, as well as injector codes, and find somebody with EFI Live to look into your mapping
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
Unfortunately no codes at all. I messed with it today coming home with no exhaust brake. It seemed like it was getting to much fuel while I was coasting. The turbo was singing like it does at cold weather high idle even though I’m coasting. The second you give it throttle to accelerate it quits smoking. I’ll have to look into the EFI live suggestion. I’ll buy it if I have too , to figure something out. I’m going to suggest to my mechanic to meet me at the job site with his computer setup and monitor it as I drive. Thanks for the input
 

·
Beware the Underbite!!!
Joined
·
6,704 Posts
Sounds like your turbo actuator or the circuitry associated with it could be at fault too
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #7 ·
Cmh2007 , that is interesting you mention that. While I was in talking with my mechanic he told me to prepare to replace that actuator because they are failing at a high rate in this year of pick up. I’m going to swing by there this evening and visit with him I’ve noticed recently in the mornings it sounds like my exhaust brake is on while I am accelerating up to so many RPMs and then it kicks off. He mentioned my pick up is the first one he’s ever seen that does not have a (turbo pressure switch) I think he called it. He said he dug into it and my EFI live must have a program on it that tricks the vehicle when they kick on and kick off which moves that actuator but he says from what he can tell it has no idea when to do that based on psi.
 

·
Registered
Joined
·
1 Posts
Hey guys,
2016 2500 69,000 miles 6 speed man. full delete EFI live. I purchased it this way. Never could work the previous owners name out of the dealership to ask about tune. Doing a cabin addition at 6000 ft this spring. After truck sits for 5 hours or so when i would start it , blowing blue/white smoke and running terribly rough, more throttle the worse it got. Coming down off the mountain exhaust brake on still smoking. If you give it just enough peddle to stop the exhaust brake smokes like crazy like something from a bat man movie. In 3 miles or so it stops runs like a dream. Absolutely no symptoms at home that ive never saw. Start it every morning and now im watching it of course and nothing no smoke no rough idle. Took it to my trusted local mechanic, his first thought was a dripping nozzle that wasnt sealing up , pulled injectors sent them to bosch for testing. Nothing wrong with injectors but replaced tips anyway. No change , more testing determined that #1 or 5 cylinder is cause of smoke. He replaced one of them (i never asked which), adjusted my valves and said come get it and drive it, but i could tell he wasnt sure. Drove it for 3 weeks back to same job same exact scenario no apparent issues. Fixed finally. 2 months later same deal up steep driveway for a couple miles for countertop installation. Parked for 8 hours , fire it up running just fine no reason to think anything , using exhaust brake instead of foot brake , something catches my eye in the mirror , smoking like crazy. Now im working 4 miles from my house driveway is so steep 4 wheel drive is the only way to keep from spinning in the gravel. Work for 8 hours start it runs great no smoke no nothing, in 2 miles coming home smoking like crazy worse than before. As soon as you you touch the throttle to avoid exhaust brake its insane smoke. If you give it a tiny bit more throttle like to accelerate it quits smoking . At the bottom of the hill leaving stop sign and accelerating runs great no smoke absolutely nothing until the next day leaving work. Im at a total loss. No codes no nothing. Having great luck lately Toyota just lost the head gasket so as soon as i get it back the diesel goes in, but throwing $$ at it is getting expensive. Just looking for recommendations or something to look at ?, look for? Anyone?
Thank you
Hey there , i have a 2016 fully delted and i have same issue as i described here , have u got your truck fixed ? Also the smoke on mine showed up right the fisrt trip i made with my new turbo , i had some knoking from the actuator and i tought it's the turbo , the shop replaced it then the smoke showed up only when i use the exhaust braking as soon as i accelerate its all gone plus some of the power is gone , please please let me know if u had it fixed , i want to fix mine too
Thank you
 
1 - 8 of 8 Posts
Top