DodgeTalk Forum banner

Status
Not open for further replies.
1 - 5 of 5 Posts

·
phahengpro
Joined
·
123 Posts
Discussion Starter #1
Hey guys,

I recently installed a new throttlebody on my D. I've noticed that it seems to have better pick up, but sometimes it almost feels kind of loose, or sluggish, like it has an occasional miss. It didn't have this problem before I changed the tb. I followed Dan's instructions when installing it. I thought I might get some answers here before emailing and bugging him as he seems to stay pretty busy. I'd really appreciate any advice or suggestions. Thanks in advance!!! :D
 

·
Hummer Recovery Vehicle
Joined
·
6,250 Posts
thottle linkage isn't loose is it? also, u did'nt damage a sensor when swapping them over did you? first things that came to mind.
 

·
phahengpro
Joined
·
123 Posts
Discussion Starter #3
Hey cbrenn71,

When I changed it I thought the cables looked like they had less tension on them. I looked at them a bit this morning, but I couldn't see any way to tighten up the slack. I'll look into it when I have more time and it's not raining.

Thanks!
 

·
Registered
Joined
·
96 Posts
You need to reset your pcm when you change it as well. If you did, it'll run rich for 40-50 miles or something like that I think. Either way, that could cause a sluggish feeling. (I think)
 

·
phahengpro
Joined
·
123 Posts
Discussion Starter #5
Hey guys,

After driving it I've decided that it is just a different feel. It has better acceleration when you need it (not gonna set any 1/4 mile records or anything-but a little more get up) which is what I was shooting for. I think there is just a different feel to it since I installed the new tb (possibly in the tb spring). Thanks for the advice.
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top