DodgeTalk Forum banner

Status
Not open for further replies.
1 - 20 of 22 Posts

·
Vinny
Joined
·
938 Posts
Discussion Starter #1
Can you use the Slammed1 2" drop shackles on a 4x4? My suspension is stock and there is way too much space in the rear wheel wells and I want to lower the rear end a little. Also, is it an easy install?

Here's what my truck looks like now:



Here's a photochop of what my truck might look like with the drop:

Vin's truck leveled 4 DT.jpg
 

·
Serenity
Joined
·
5,947 Posts

·
Vinny
Joined
·
938 Posts
Discussion Starter #3
I have them on my 04 RC/SB. The install was not bad at all - I also removed the overloads since the regular cab does not drop as far as the quad cab with just the shackles. Here are a couple of links:

http://www.slammed1.com/howto.html

http://www.dodgetalk.com/forums/showthread.php?t=31123&highlight=overload
Wow thanks! That helps a ton. Do you like the way your drop turned out? I'm trying to figure out whether or not just using the shackles will drop it enough for me to be happy. I really don't want to go through the extra work of removing the overloads haha, but if I feel it's necessary then I'll do it. :rck:
 

·
Serenity
Joined
·
5,947 Posts
Wow thanks! That helps a ton. Do you like the way your drop turned out? I'm trying to figure out whether or not just using the shackles will drop it enough for me to be happy. I really don't want to go through the extra work of removing the overloads haha, but if I feel it's necessary then I'll do it. :rck:
I am happy with it - the ride did not change at all - I just think the rake is way too much on the RC/SB and I was not interested in raising the front at the time.

It is no problem to just install the shackles and see how you like it. The truck will also settle for a while, so wait a few weeks and if you want to go that extra 3/4" or so, you can remove the overloads. Here was an original dealer pic when I got it used, then how it looked a few months ago. Still not level, but close enough for me ...
 

Attachments

·
Vinny
Joined
·
938 Posts
Discussion Starter #5
I am happy with it - the ride did not change at all - I just think the rake is way too much on the RC/SB and I was not interested in raising the front at the time.

It is no problem to just install the shackles and see how you like it. The truck will also settle for a while, so wait a few weeks and if you want to go that extra 3/4" or so, you can remove the overloads. Here was an original dealer pic when I got it used, then how it looked a few months ago. Still not level, but close enough for me ...
Oh wow that looks sweet!!! I love the flares, wheels, and mirrors!!!

The drop definitely made a difference. It filled up all that space in there nicely. I'm definitely doing this mod!!!
 

·
Registered
Joined
·
31,160 Posts
You will need some 21 MM wrenches, a T55 bit and a jack!

I have done this a few times.......just took mine off yesterday. Truck looked great, just decided to lift the front instead!
 

·
Vinny
Joined
·
938 Posts
Discussion Starter #7
You will need some 21 MM wrenches, a T55 bit and a jack!

I have done this a few times.......just took mine off yesterday. Truck looked great, just decided to lift the front instead!
Okay cool, I have that stuff. I'm excited to do this!!!

Do you have any before/after pics? :D
 

·
Vinny
Joined
·
938 Posts
Discussion Starter #8
ggravant, did you take your wheels off when you did the shackles?
 

·
Vinny
Joined
·
938 Posts
Discussion Starter #11
wheels do not need to come off......unless you do the overload spring removal.
Okay GOOD haha I was not looking forward to taking my wheels off. I'm lazy :D

I'll check out that thread now.
 

·
Vinny
Joined
·
938 Posts
Discussion Starter #12
What did you do about the squeaking?
 

·
Registered
Joined
·
31,160 Posts
Took 'em off! I pulled them yesterday and put the original shackles back on.

oh.....and a leveling kit for the front!
 

·
Vinny
Joined
·
938 Posts
Discussion Starter #14
Took 'em off! I pulled them yesterday and put the original shackles back on.

oh.....and a leveling kit for the front!
Yeah I know you did that lol, but I mean was there a reason they were squeaking? Did you just not lube them up enough?
 

·
Registered
Joined
·
31,160 Posts
Trust me.........there was plenty of lube on them. Tried with lithium grease and black grease of some sort. Both times they started squeaking.

It could have been the springs, they are at a different angle now......etc - who knows. I got tired of fooling with it - so I ditched 'em.

No squeaking from the stockers. Ran over some pretty rough terrain yesterday and didn't have any noise.

Oh - and I told Gary I wouldn't complain about 'em anymore. So listen up Gary - no complaining here, just the facts! (in my case anyway). :tup:

:D
 

·
Vinny
Joined
·
938 Posts
Discussion Starter #16
Trust me.........there was plenty of lube on them. Tried with lithium grease and black grease of some sort. Both times they started squeaking.

It could have been the springs, they are at a different angle now......etc - who knows. I got tired of fooling with it - so I ditched 'em.

No squeaking from the stockers. Ran over some pretty rough terrain yesterday and didn't have any noise.

Oh - and I told Gary I wouldn't complain about 'em anymore. So listen up Gary - no complaining here, just the facts! (in my case anyway). :tup:

:D
Haha okay, I hope this doesn't happen to me!!! Does EVERYONE have this problem? Or did you just have a bad set or something? Because now I'm not so sure I want them if they squeak :YO:
 

·
Serenity
Joined
·
5,947 Posts
Trust me.........there was plenty of lube on them. Tried with lithium grease and black grease of some sort. Both times they started squeaking.

It could have been the springs, they are at a different angle now......etc - who knows. I got tired of fooling with it - so I ditched 'em.

No squeaking from the stockers. Ran over some pretty rough terrain yesterday and didn't have any noise.

Oh - and I told Gary I wouldn't complain about 'em anymore. So listen up Gary - no complaining here, just the facts! (in my case anyway). :tup:

:D
I didn't say you were complainin' ;) At least when you modified your truck and it squeaked, you blamed it on the mod and not Dodge for making trucks that squeak when shackels are changed :D

Oh and mine do not squeak (that I can hear anyway ...)
 

·
Registered
Joined
·
31,160 Posts
this exact set of shackles worked fine on Prism's truck. so its not all of 'em......probably user error!
 

·
Registered
Joined
·
16,621 Posts
I have them on both of my trucks. Both 4X4's
 

·
Vinny
Joined
·
938 Posts
Discussion Starter #20
this exact set of shackles worked fine on Prism's truck. so its not all of 'em......probably user error!
Haha I'm sure it's not user error :D

This is off topic but I just went out and bought a Kenwood 1800 watt amp with a 12" kicker CVT. It's getting installed in March, I'm sooo pumped.
 
1 - 20 of 22 Posts
Status
Not open for further replies.
Top