DodgeTalk Forum banner
Status
Not open for further replies.
1 - 12 of 12 Posts

·
double over head
Joined
·
179 Posts
Discussion Starter · #1 ·
hey all been a while since i logged in... trucks been running great until now.
I have a problem that maybe old since I dont ever use my heater in san diego.
For the past couple months I have notice the antifreeze in the over flow is a little low so i put some water in, the radiator is always full. no leaks anywhere and the oil looks normal. no worries. now im on the road and in colorado and i notice the temp gauge seems lower than normal and the heater is blowing cool air. when I stop or slow down the temp gauge gets very hot approaching 260 and then spontaneously will go back to normal. the engine does not seem to be getting hot during this time. Soooo. I replaced the thermost with a stock 195 temp and replaced the radiator cap. now the heater is blowing hot air but when I stop/slow down I get this surge of high temp on the gauge and then it just goes down all by itself after just a few minutes. I plan to change my clutch fan at my next stop... no check engine light, its running great.
any other suggestions? thanks, sorry fot the long post! Ill be offline until tonight!
 

·
double over head
Joined
·
179 Posts
Discussion Starter · #2 ·
uuuughhhh thanks for all the great feedback? no one on dodgetalk anymore?!
what happened! Im thinking gauge problem or clutch fan... will likely change the clutch fan first since thats the easy fix, rather than chasing a ground.
 

·
double over head
Joined
·
179 Posts
Discussion Starter · #3 ·
maybe I was too scattered in my post... everything is fine with the truck except the temp gauge is climbing rapidly to about 260 degrees and then will spontaneously (after about 10 seconds) drop rapidly down to normal operating temp. Not ever happening when driving around only when stopped... the kicker is if its the fan why does the engine not actually get hot? I might be making this up but could it be the ECM and associated with the cruise control being turned on?
 

·
WORLD'S GREATEST TRUCK
Joined
·
4,435 Posts
What're you, my wife telling me when to go online? Do you hang with Timstone? First of all, I work, so I don't read this stuff all day long. Second, Tues. is darts night. Third, you probably have air trapped in your system.
 

·
Registered
Joined
·
4,953 Posts
Dang, did I miss darts night AGAIN? LOL

Ditto, on the air in system...
 

·
AKA: Justin
Joined
·
190 Posts
Like Paul and Warren said, Sounds like air in the system
 

·
double over head
Joined
·
179 Posts
Discussion Starter · #7 ·
AIR!!!.... oh wait. thanks for replying... can i run the truck with the radiator cap until the thermostat opens up.... how did it get in there?
 

·
Pimp On Sir Don
Joined
·
12,782 Posts
You're truck needs beano and WTF I didn't know there was a dart game! ARGH! No one ever tells me these things!

IDK how it got in there before you replaced the Tstat but when you did that is probably a good place to start. ;)

Could be a bad water pump not pushing water like it should at low RPMs no?
 

·
Registered
Joined
·
4,953 Posts
Paul/Don - Last time I went to NY for darts I got my (_|_) kicked (in more ways than ONE!)
 

·
WORLD'S GREATEST TRUCK
Joined
·
4,435 Posts
WarrensD said:
Paul/Don - Last time I went to NY for darts I got my (_|_) kicked (in more ways than ONE!)
Good thing it wasn't lawn darts.
 

·
double over head
Joined
·
179 Posts
Discussion Starter · #11 ·
thanks for all the help... I pulled the rad cap and let her run until the t stat opened up and filled it up.... seems much happier.... thanks again
 
1 - 12 of 12 Posts
Status
Not open for further replies.
Top