DodgeTalk Forum banner

Status
Not open for further replies.
1 - 7 of 7 Posts

·
Registered
Joined
·
462 Posts
Discussion Starter #1
Wow, reverse died after a harsh backup, I'm reeling.
Next time I tried to back up its like its in neutral, nothing. Never showed any signs of failure before, Fluid level is good, is there ever anything simple that can cause a tranny not to respond to reverse ?
 

·
Registered
Joined
·
462 Posts
Discussion Starter #5
Sun shell and splines are a new one on me, I was told by a tranny guy most likely I popped a band and would need a rebuild.
Still haven't dropped the pan.

So I am just living without reverse, not the first time but I don't know how long I can take it.
 

·
Registered
Joined
·
381 Posts
Different transmission have different issues. Broken sun shells are not that uncommon in GM RWD transmissions like the 4L60E, for example. The Chryslers I am less familiar with, but the basic designs are similar, I assume. I've never seen one "pop a band", but I suppose it's possible. If you broke something, you're going to need a rebuild anyway, or, what I would do, just swap another one in.
 

·
Registered
Joined
·
462 Posts
Discussion Starter #7
Mine is 4WD.
Not even sure what tranny it is, VIN tells me nothing. From what I understand, the reverse band going out is not uncommon in these trucks - My last Ram, a 1996, had the same issue, went almost a year with no reverse then, what a PITA.
Eventually got a rebuild for $800, but that was with me bringing the tranny in and reinstalling it myself.
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top