DodgeTalk Forum banner

Status
Not open for further replies.
1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I have a '99 Ram1500 with factory radio that lights up but no sound comes thru the speakers. I have switched factory radios with 2 I got from a junk yard with same results. The radio used to kick on awhile later after the truck warmed up, but now I get no sound, period. I removed the radio and checked for continuity on both speakers (by testing the same speaker on the black and grey harness clips)- I got higher readings for the left (25 ohms) then I did on the right (3 ohms). I don't believe fuses are an issue since the radio does power up. The ground wire to the radio itself seems stable. Since I can't see thru steel, I am not sure where, if any, breaks may exist in any of the lines. All the wires I checked had no obviosu signs of damage. I will be getting a spare speaker soon to hook up directly from the radio, before I start pulling door panels apart to see if the speaker wires near the speakers themselves are at issue. Am I missing an obvious fix, here? If the speaker wires are an issue (presumably at some junction point since both speakers are not sounding up), can I rewire the truck with new speaker wire and solve my problem? Or, is there some other reason why the radio turns on but no sound comes out? Thanks for reading my post and offering any suggestions. Manny
 

·
Big Green
Joined
·
8,318 Posts
if it has the infinity system there is a factory amp which splits the sound to the doors and the tweeters in the window pod. If that is out no sound would come out either with a good head unit. Try hooking up directly to the head unit and see if sound comes out then I would say it is that.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
I am not sure if this is Infinity or not (I see no markings for Infinity). Where is the amp that you are talking about located in the truck?

Thanks.
 

·
Big Green
Joined
·
8,318 Posts
Look at the front windshield are there little round speakers in the pods that run up the window on each side these are the tweeters. The piece i am talking about is under the dash. Mine is behind the glove box. Mine doesn't say infinity either. This splitter or amp what ever you want to call it is what gives the highs to the little round ones and the lows to the coxials this is also the reason if you hook up a aftermarket radio without the blue remote the head unit will do the same thing as your factory is doing.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
No tweeters, so no infinity I guess.

In the meantime, my left speaker quit altogether and now my right one comes on as I drive along. Sometimes the right door speaker kicks on when I start the truck, but most times the gremilns turn it on when I'm halfway to work, or coming home later in the day. Since my singing hasn't improved much, does anyone know what I need to do to get both speakers working, all the time?
 

·
Registered
Joined
·
631 Posts
There are two causes that I could think of with your problem;

A loose wire(s) for your front speakers

Your speaker(s) are done and you need new ones.

Try running new wires to the existing speakers to see if that solves the problem. If no dice, then get some aftermarket 6x9 speakers to replace the stock ones.

Good Luck!
 

·
Registered
Joined
·
5 Posts
Discussion Starter #8
It was the speakers all along. The factory speakers are made in Mexico ("Audiolatina"). I have some Japanese speakers in there now. Let's see how long they last.

Thanks Elliot and Greg for chiming in with good advice.

Manny.
 

·
Registered
Joined
·
631 Posts
I'm just glad you fixed the problem!
 

·
Big Green
Joined
·
8,318 Posts
Those will probably out last the truck sadly.
 
1 - 10 of 10 Posts
Status
Not open for further replies.
Top