DodgeTalk Forum banner

Status
Not open for further replies.
1 - 5 of 5 Posts

·
HEMI ROCKS!
Joined
·
273 Posts
Discussion Starter #1
The A/C pump kicks on and the the fan by the condenser but no cold air the cold side gets frost on the line right up to the air box and then it stops, from there it runs to the condenser. Does it need to be topped off or do I have other problems? I need some help with this I hope you guys can help. I am really pissed about this happening to an 04 with 59000 miles on it. Thanks Greg
 

·
Great View
Joined
·
1,048 Posts
Frost on the line is a sign of low freon. They can leak out slow and even with dye in the system they can't always find the leak. Had a 95 ram that had a slow leak and the first couple of times they looked for it and couldn't find it, so they would just top it off. After that I just topped it off myself and saved a bunch of money.
 

·
HEMI ROCKS!
Joined
·
273 Posts
Discussion Starter #3
Thanks Piper18 I will top it off. Was worried that something was really wrong. Thanks for the fast reply I appreciate it.
 

·
Registered
Joined
·
88 Posts
Same problem hear. I topped it off, but I think I overfilled it and it got worse. Some bled out and it seemed to get better, but today I couldn't get it to blow cold.
 

·
Admin - David Mack
Joined
·
30,924 Posts
Dodge had to put a dye marker in the system before they were able to find my leak. I was more than happy to let them play around with it because the truck was only two months old and I wanted my A/C fixed.
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top