DodgeTalk Forum banner
Status
Not open for further replies.
1 - 13 of 13 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter · #1 ·
Hey guys,

Just picked up a used quadzilla module. How can I figure out which module it is??
It has a small toggle switch with 3 settings. The box itself looks like the attached pic
any info is great
Thanks
 

Attachments

·
running on 6 cylinders
Joined
·
543 Posts
holy cow is that old!. ha ha. that wont fit your 03 possible not even your 97. lol
 

·
Registered
Joined
·
58 Posts
Discussion Starter · #3 · (Edited)
holy cow is that old!. ha ha. that wont fit your 03 possible not even your 97. lol
Tried contacting Quadzilla with an e-mail and they were quick to respond.
The gentlemen that replied stated that "the module is one of our older products. The module is adjustable with an off, 50hp and 100hp settings. The 50hp setting is for increased mileage and towing and the 100hp setting is the performance setting and should not be used while towing also that it will work on 03-04 trucks."

I'm going to try and figure out if I can install this today and post up results when completed...
 

·
running on 6 cylinders
Joined
·
543 Posts
wow I never would have thought it was new enough.

if you decide you dont like it or cant use it I am probably going to get rid of my quad set up. I am going to try and reach 200hp. I am on the list for preorder quadzilla adreniline for 3rd gens.
 

·
Registered
Joined
·
58 Posts
Discussion Starter · #5 ·
well I just got it hooked up I'm going to try it out and see how she works....
 

·
Registered
Joined
·
58 Posts
Discussion Starter · #6 ·
Well I took it for a spin.. definitely notice it there. Now I just have to figure out the positions as they are not marked/indicated and don't want to have it on the 100hp setting all the time
 

·
Registered
Joined
·
58 Posts
Discussion Starter · #7 ·
Would this module be considered a pressure box???
 

·
running on 6 cylinders
Joined
·
543 Posts
I dont know how they made them back then but for their boxes that I have run (last 4 years) they do a little of everything.
 

·
Registered
Joined
·
58 Posts
Discussion Starter · #9 ·
So far the box has been great but it keeps tripping my check engine light with codes P0237 Map sensor voltage too low
P0193 Fuel pressure sensor voltage too high

Is there an easy fix to prevent this?? When I unplug the box the engine light goes away. I plug it in again and it's good for about a day than engine light shows up again..
 

·
Registered
Joined
·
810 Posts
Get some di-electric grease and put a little on the connectors, then make sure they click into place. Last but not least wire tie the harness to the other harnesses in the area so it can't move around. I have had the same issues with my XZT box from quad.
 

·
running on 6 cylinders
Joined
·
543 Posts
people have simular issues with all harnesses. I recomend dialectric grease on all electrical connectors
 

·
Registered
Joined
·
58 Posts
Discussion Starter · #12 ·
Thanks for the help everyone will post up I make out. Just put some dielectric grease on hope this fixes the issue as it runs like crap when it throws the engine light/codes
 

·
running on 6 cylinders
Joined
·
543 Posts
and also remember you are running a really old product, electronics wear out too.
 
1 - 13 of 13 Posts
Status
Not open for further replies.
Top