DodgeTalk Forum banner

What should I do?

  • New Truck?

    Votes: 0 0.0%
Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I have a 2004 Dakota 4.7L SLT 4WD. I am having an issue where the motor will sputter/kick when accelerating. This can be at 0-30mph or sometimes it will happen when i reach 40-60mph and will not stop unless I release the gas. If I continue to press the gas the check engine light flashes and then stops after releasing the gas again. There is a loss of power. This issue does not happen all the time. It happens at random as sometimes my truck is running smooth and no loss of power. If anyone has a solution or had the same problems please let me know what you did to fix the issue. I have replaced the Throttle Position Sensor and looked into the EGR Valve but my truck does not have one.
 

Attachments

·
Registered
Joined
·
4 Posts
Discussion Starter #2
Still working on getting this fixed. So far by what Ive seen the reason it was kicking was because cylinder 7 and maybe 3 were miss firing. All ignition coils were corroded and some the rubber boot was torn and O rings busted. I have currently replaced the spark plugs with proper iridium spark plugs. Awaiting new ignition coils and replaced any hoses that looked cracked. It was throwing out a code for the small evap leak but I did find the cracked hose. I will be cleaning the throttle body as when I took it off it was really dirty.

Now I am currently waiting on the air manifold to cylinder head bolts to come in as 2 of them snapped on when removing the ignition coils. Best advise for this is make sure you let the bolt set in WD40 for at least a day. After noticing how rusty and seized up they were, I lubed the rest and they came off find after continued lubing. I will be replacing all 8 either way to avoid any other problems later.

I will attempt to replace them this weekend. If anyone knows how to replace them with less hassle please let me know. It doesn't look like a hard fix but if anyone can throw me some pointers, I'd appreciate it. I will keep you all posted on the out come so if anyone else has the same issues.
 

·
Registered MOPAR User
Joined
·
9,350 Posts
If your paid off on truck, keep it.

Still looks great!
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4 (Edited)
Just an update on the current issues I have been having. I received new ignition coils yesterday and swapped them out. I also added some Lucas transmission treatment. Not much just enough to lube it. Cleaned the throttle body which was dirty. I have noticed the quicker response, no kicking at 30-60mph and quicker shifting. I am sure this cleared up all the problems I was having.

I plan on keeping it as its a beast of a truck.
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top