DodgeTalk Forum banner

Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
119 Posts
Discussion Starter #1
as you can tell from the title i fear that i have a leak or something. i noticed that i was low the other day, so i checked it, and yep it was almost bare. so i filled her up and everything was all good. until the other morning i noticed a small puddle of the fluid under my truck.

is there something i can do, or do i need to take to a shop. (i consider myself pretty handy but in no way a mechanic.)

thanks guys
 

·
Serenity
Joined
·
5,947 Posts
It is very common for the clamps from the two hoses that run from the PS cooler in front of the radiator over to the rack and pinion to leak from the clamps (four total) - they are not that good. You can just get some screw clamps (the "worm gear" type) at Home Depot and add them right next to the existing clamps. Tighen them down and it should work. I ended up using a dremel to carefully cut off the existing clamps and replaced them with the screw clamps just because I am anal. Whatever you do - do not remove the hoses! That may cause air to get in the system which can be a PIA to get rid of.

You may also want to pick up some brake cleaner to clean all the hoses and the rack and pinion so you can tell that the leaking has stopped
.
 

·
Registered
Joined
·
119 Posts
Discussion Starter #3
thanks ggravant, ill check it out when it's light outside.
 

·
Serenity
Joined
·
5,947 Posts
04oklaram said:
thanks ggravant, ill check it out when it's light outside.
Sure, no problem - hope that is the issue with yours. When I bought my truck used back in February, others here on DT suggested the clamps and in my case it has been dry as a bone since.
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top