DodgeTalk Forum banner

Status
Not open for further replies.
1 - 8 of 8 Posts

·
Registered
Joined
·
2,168 Posts
Discussion Starter #1
ok so my uncle has a 6.7 cummins and he wants bright lights. im gonna do the 9005 conversion but i cant seem to find 9008 or H13 bulbs from piaa. they seem to be pretty brights and i wanna stay with the same brand and company can anyone point me in the correct direction where i can get them all from one place online. thanks
 

·
5 Years... 6 Dodges
Joined
·
25,280 Posts
I'm not certain... but I think omly Sylvania has the H13 bulbs... but it's been awhile since I looked.
 

·
Master Baiter
Joined
·
661 Posts
I don't know about Piaa, but Nokya makes the H13 bulbs. I don't use that number since I've use 9007's and 9006's (9005's after I do the mod), but I've been using the Nokya Arctic White bulbs for almost 3 years now and I can tell you that I've never seen any brighter bulbs than the Nokyas. If he wants bright bulbs, try them out. You won't be disappointed. :cheers:
 

·
Registered
Joined
·
144 Posts
Did you have stage 1 or stage 2 Nokya bulbs? Is there any problem going upto a 100w bulb? Thanks

spinfreak said:
I don't know about Piaa, but Nokya makes the H13 bulbs. I don't use that number since I've use 9007's and 9006's (9005's after I do the mod), but I've been using the Nokya Arctic White bulbs for almost 3 years now and I can tell you that I've never seen any brighter bulbs than the Nokyas. If he wants bright bulbs, try them out. You won't be disappointed. :cheers:
 

·
Master Baiter
Joined
·
661 Posts
08RamLaramie said:
Did you have stage 1 or stage 2 Nokya bulbs? Is there any problem going upto a 100w bulb? Thanks
I've used the Stage 2's since I started using them almost 3 years ago. The only problem I ever had was a burnt connector on the fog harness on one of the bulbs. It was due to a loose connection though....nothing to do with the bulbs. Some people have said that you could have problems with the higher wattage bulbs, but as for myself, I haven't had any. :rck:
 

·
Registered
Joined
·
144 Posts
spinfreak said:
I've used the Stage 2's since I started using them almost 3 years ago. The only problem I ever had was a burnt connector on the fog harness on one of the bulbs. It was due to a loose connection though....nothing to do with the bulbs. Some people have said that you could have problems with the higher wattage bulbs, but as for myself, I haven't had any. :rck:
Thanks
 
1 - 8 of 8 Posts
Status
Not open for further replies.
Top