DodgeTalk Forum banner

Status
Not open for further replies.
1 - 20 of 42 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #1
Hi folks,

My first posting, although I have been reading for a while and you guys have always helped with my Ram problems... Thanks

I have a 2004 Dodge Ram 1500. The parking light stay on all the time, only way to shut them off is either by disconnecting battery, removing the relay or by removing the 50A fuse for the parking lights.. I have checked all the fuse and all seem good. This problem showed up all of a sudden, the truck was sitting idle for about 3 days, when I went outside suddenly the lights were on...

I have read a few posts like this one, before I decided to post BUT there's never a solution posted.

PLEASE HELP>!!!!! getting tired of opening the hood everytime I park the truck... :)

Bauds
 

·
User
Joined
·
873 Posts
Did you try replacing the relay? It sounds like the relay could have gone bad stuck on.
 

·
Clifford'04
Joined
·
160 Posts
x2
 

·
Registered
Joined
·
23 Posts
Discussion Starter #4
I've tried to replace the one in the fuse box with another one that I know worked.. and no luck...
 

·
Admin - David Mack
Joined
·
30,924 Posts
* subscibe *
 

·
Registered
Joined
·
539 Posts

·
Registered
Joined
·
4,029 Posts
sorry how do I subscribe ?
The best way is to go to the top of the page look for thread tools and subscribe though that method.

The other way is to just post anything in the thread and you will be subscribed to it, but then anyone else, subscribed to that thread, has to look at your post. :ugh ;)
 

·
Registered
Joined
·
3,747 Posts
maybe a headlight switch went bad? Sounds to me like something is shorted out keeping them on
 

·
Clifford'04
Joined
·
160 Posts
Do you have to leave the fuse out? Do they turn on automatically when you start the truck? Only when you turn on the lights? More details. pls
 

·
Registered
Joined
·
23 Posts
Discussion Starter #12
I have tried removing the headlight switch and the lights still stay on.. from other threads if the lights stay on after removing the connection from the switch..the switch is not the problem...

If I put the fuse in the lights come on and stay on .. with or without the truck running. I can turn on the headlights and turn them back off and still the parking lights stay on...

I have seen forums with others having the same issues, but never a solution..

Thanks for all your replies so far... please keep your ideas coming I will try anything..
 

·
Clifford'04
Joined
·
160 Posts
What about keyless entry? Is that functioning correctly? Maybe the relay in that is sticking?
 

·
Registered
Joined
·
23 Posts
Discussion Starter #14
Keyless entry is fine. panic alarm is fine. hazards are fine. I'll check the relay for that as soon as I get home..thanks..
 

·
Work In Progress
Joined
·
1,321 Posts
I think it might be the computer. Aren't the lights ran through the computer on these trucks?
 

·
Admin - David Mack
Joined
·
30,924 Posts
Did you try removing the headlight switch and then checking the lights? If the problem is the switch, the lights would go out. If the lights are still on, it's a relay or the computer.

:)
 

·
Registered
Joined
·
23 Posts
Discussion Starter #17
I have removed the switch and the lights stay on....
Wouldn't the computer throw a code of something.?
 

·
Work In Progress
Joined
·
1,321 Posts
Not if the lights are stay on. It would throw a lamp out light if the lights weren't staying on. It just sounds like a resistor or something on the computer mobo that tells the lights to turn off isn't working properly.
 

·
Registered MOPAR User
Joined
·
9,350 Posts
Welcome camyan,
Sounds like the BCM is not seeing the "Off" trigger. The BCM is part of the speedo cluster, as far as I've heard. Pull your fuse first, pull switch next, replace fuse 3rd w/ HL removed, see if PL turn on.
Also the BCM has a 2 minute or maybe longer, around 10 minutes, before it shuts of headlights/ interior lights. Have you tested to see if that function works?
 

·
Registered
Joined
·
23 Posts
Discussion Starter #20
DizzyD thanks... the BCM function works well... no problem there..Tomorrow i'll try you're first suggestion for pulling fuse and switch...

Thanks everyone for your inputs.. I'll get it someday.!!!!! :)

I'll keep you posted... I ordered a new headlight switch .. at this point i'll try anything...
 
1 - 20 of 42 Posts
Status
Not open for further replies.
Top