DodgeTalk Forum banner

Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Started my truck yesterday morning (91 Ramcharger 318 auto 2wd) and noticed that the parking brake and anti lock dash lights stayed on. Checked parking brake, it was not engaged. Engaged and released it, put in reverse, backed up, put in drive and no draging or lack of power. Stopped. Checked fluid it was o.k. Disconnected battery, reconnected, restarted and the lights did not come back on. Drove all day, on and off. Today, started lights still out. drove about 2 miles and the lights came on again. New calipers installed in early 2005 new pads also. Rear brakes and drums early 2005. The rotors in the front are older i.e., not replaced since I have owned this truck. Took a trip from Colorado to Texas last month and had brakes inspected before trip because I would be towing a trailer. That was about a month ago. I am giving as much info as posible. WHAT COULD BE THE PROBLEM?
 

·
Do It In A Van
Joined
·
8,045 Posts
This is rear-ABS only right? I would venture to say that the speed sensor on the rear axle is going bad or there's a wiring problem to the sensor.

If there's a problem with the ABS system, both lights come on.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Thanks. I took it to My Mechanic and they hooked up test equipment and told me that the REAR WHEEL SPEED SENSOR has failed. About a $65.00 part.
 

·
Do It In A Van
Joined
·
8,045 Posts
Happens every time....it's 99% the speed sensor.
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top