DodgeTalk Forum banner

Status
Not open for further replies.
1 - 20 of 20 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hi again, Once in a while my park brake lite and ABS lite come on for no apparent reason (always together). Is there a sensor i should check etc? Thanks!!
 

·
Registered
Joined
·
2,168 Posts
It may refer to your rear speed sensor located on the rear axle differential pumpkin.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
Ok...read a bit and now i am sure to check the speed sensor on top of the rear dif. That makes a bit of sence being that i am now having trouble with the speed going on and off.
 

·
Registered
Joined
·
2,168 Posts
Not a problem. Glad you found it out. Good luck!
 

·
Registered
Joined
·
48 Posts
just had the same thing. speedo wouldnt work till i hit 20-25 mph, abs lite and brake light on, trans slipping. replaced the speed sensor in the rear and everything is fine again. glad tranny wasent going..
 

·
Registered
Joined
·
38 Posts
HEY--my abs and brake light has been on,i changed the sensor on the differential,topped off the brake fluid,disconnected the battery to try and get the light off,and still they both stay on?--any ideas--thanks
 

·
Registered
Joined
·
803 Posts
hey rowdy I would suggest you open up your rear diff and see if maybe you broke a tooth off your tone wheel. I had my ABS light on and brake and when I replaced the sensor it still came on. Opened my diff and found out I broke a lot of pieces b/c my clutch packs broke and they ended up breaking more.
 

·
Registered
Joined
·
38 Posts
hmm---would there not be a noise or anything if that were so---and how did you break yours off,by normal wear and tear or what,and one last thing--did that make the lights go off?----thanks
 

·
GROUNDED
Joined
·
2,944 Posts
crazys182003 said:
hey rowdy I would suggest you open up your rear diff and see if maybe you broke a tooth off your tone wheel. I had my ABS light on and brake and when I replaced the sensor it still came on. Opened my diff and found out I broke a lot of pieces b/c my clutch packs broke and they ended up breaking more.

you wouldnt happen to have a pn for that wheel?
 

·
Registered
Joined
·
803 Posts
I broke my parts from driving around my construction site. I ended up hitting a rock and broke them. My mechanic said the clutch pack is a normal thing that does break but not the rest of the parts. Once I had everythign replaced and had my light reset it stayed off ever since. I didn't hear a noise while I drove it but when I was outside and had someonelse drive it I heard a whining sound but that was only after about 3-4 weeks of driving with my light on. I got a 2001 Dodge RAM 1500 318 5 speed. Here is a list of the parts I had to buy and replace alogn with their PNs.

PN# Description
52070340AB Seal-Drive Pinion
01820552 Bearing-Drive Pinion
01820551 Cup-Drive Pinion Bearing
52070427AB Seal-Axle Drive Shaft
05010884AA Sealer-RTV
03723148 Cup-Differential Side Bearing
03723149 Bearing Differential
05017438AA Bearing Drive Pinion
03507678 Spacer- Drive Pinion Bearing
04384227 Tone Ring- Sensor
0080754A Posi
04318060AB Lubricant- Axle
56028187AE Sensor- Wheel Speed
 

·
Registered
Joined
·
12 Posts
ive had the same poblem for about a year and a half now and just ordered the speed sensor, but i was wondering if that would have anything to do with the cruise control not working also?????
 

·
Registered
Joined
·
227 Posts
ROWDY69ER said:
MY new sensor on the differential did nothing for the light---i will check on the other stuff a little later---thanks

I am having the same problem...... where did you get your new sensor?

Thanks, Ted
 

·
GROUNDED
Joined
·
2,944 Posts
crazys182003 said:
I broke my parts from driving around my construction site. I ended up hitting a rock and broke them. My mechanic said the clutch pack is a normal thing that does break but not the rest of the parts. Once I had everythign replaced and had my light reset it stayed off ever since. I didn't hear a noise while I drove it but when I was outside and had someonelse drive it I heard a whining sound but that was only after about 3-4 weeks of driving with my light on. I got a 2001 Dodge RAM 1500 318 5 speed. Here is a list of the parts I had to buy and replace alogn with their PNs.

PN# Description
52070340AB Seal-Drive Pinion
01820552 Bearing-Drive Pinion
01820551 Cup-Drive Pinion Bearing
52070427AB Seal-Axle Drive Shaft
05010884AA Sealer-RTV
03723148 Cup-Differential Side Bearing
03723149 Bearing Differential
05017438AA Bearing Drive Pinion
03507678 Spacer- Drive Pinion Bearing
04384227 Tone Ring- Sensor
0080754A Posi
04318060AB Lubricant- Axle
56028187AE Sensor- Wheel Speed

so that tone ring sensor is the actual ring itself and then the abs speed sensor reads the teeth on that. ill have to pull the pn for mine and see if it matches.
 

·
Registered
Joined
·
803 Posts
Big Joe SS/T said:
so that tone ring sensor is the actual ring itself and then the abs speed sensor reads the teeth on that. ill have to pull the pn for mine and see if it matches.
Thats exactly how my mechanic explained it to me. And sicne I had broke a few teeth off my tone wheel the abs sensor was not working properly.
 

·
GROUNDED
Joined
·
2,944 Posts
well good news, the tone rings are the same from 97-06 so all that is needed in the rear end swap i wanna do is to put my sensor in that rear end.
 

·
Registered
Joined
·
93 Posts
I had the same issue, found out with an ohmmeter that 1 of my front sensors was out. They are both the the same part number. went out and got a new one $$$$ went to replace the sensor and found I had a bad wheel bearing. More $$$$$$ later new bearing and found it comes with a new sensor. All is well now but wasted $100 on a new sensor because the bearing hub comes with one.
 
1 - 20 of 20 Posts
Status
Not open for further replies.
Top