DodgeTalk Forum banner

Status
Not open for further replies.
1 - 8 of 8 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
What's up Dodgetalk!

Recently got a completely stock 2010 2500 with a 6 speed, 6.7, and 125,000 on the clock. Truck has been great with the exception of this code and a sporadic no throttle condition. There's either very little info on the web about this condition, or I'm not searching the correct term cause I can't find much. Plus this being my first diesel it has me scratching my head.

Back story... My son and I planned a four day ATV trip with our riding group over spring break. While preparing for the trip I discovered that the parking light circuit on the 7 pin connector only had 1.5 volts. I'm assuming the TIPM there but haven't dove into the cause in depth yet. To remedy the trailer lights I used scotchloks and a jumper wire from the license plate light. The day comes to head out so we loaded up the trailer and away we went. About half way through the six hour drive my throttle pedal went dead and the check engine light illuminated. As I'm pulling off the highway the pedal comes back and all seems to be fine again. From there we managed to make it to the park and had a great time so the truck just sat there. While driving home the pedal continued to cut out but much more frequently. When this happened I would let off the throttle then ease back into it and all would be normal again. This happened sporadically all the back. Although when the truck was acting up I noticed the cruise control worked perfectly. I could maintain speed and accelerate with no issues. When I got back home I started searching and found this code was related to the APPS. Given the symptoms I bought a new pedal unhooked the jumper and away I went. About 30 minutes into my test drive the condition returned.

I’ve read this is a low voltage code and weak batteries could be the cause. Again, I’m new to diesels but this truck fires up near instantly and holds rock solid voltage while running. Needle sits at 14 volts and doesn’t budge. There are no broken or frayed wires that I can find so I don’t think that’s the cause either. The only code I get is P0698 and the electronic throttle control light will illuminate on occasion. This happens with or without a trailer.

Is there anything else I should check before I throw in the towel and take it to the dealership? Thanks in advance.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #2
So I tried a second pedal thinking maybe I got bad one. I'm in the parts business, it happens. Once again about 30 minutes into the drive, dead pedal and check engine light.

Took it to a local Dodge dealer Tuesday. They take three days to tell me a third pedal fixed the truck. In my head I'm screaming BS. I've been in the dealer parts business for a long time and I've never seen a third part fix any problem. But... They're the experts so I took the truck and drove it for about 30 minutes. Needless to say I drove the truck right back with a check engine light and the same sporadic dead pedal condition. Truck is still there.
 

·
Registered
Joined
·
933 Posts
So I tried a second pedal thinking maybe I got bad one. I'm in the parts business, it happens. Once again about 30 minutes into the drive, dead pedal and check engine light.

Took it to a local Dodge dealer Tuesday. They take three days to tell me a third pedal fixed the truck. In my head I'm screaming BS. I've been in the dealer parts business for a long time and I've never seen a third part fix any problem. But... They're the experts so I took the truck and drove it for about 30 minutes. Needless to say I drove the truck right back with a check engine light and the same sporadic dead pedal condition. Truck is still there.
Hello Rusted,

Where does everything stand since this post? If you need us to get this escalated to a Case Specialist, please let us know. We're available via direct message and would be happy to help.

Jasmine
Dodge Social Care Specialist
 

·
Registered
Joined
·
14 Posts
Discussion Starter #4
Truck has been sitting untouched at the dealer since I took it back on the Thursday. It's frustrating to say the least.
 

·
Registered
Joined
·
933 Posts
Truck has been sitting untouched at the dealer since I took it back on the Thursday. It's frustrating to say the least.
I definitely understand how this could be frustrating, Rusted. As I mentioned, we can get this over to a Case Specialist who'll try to get things moving or you can call us at 1 (800) 423-6343.

Jasmine
Dodge Social Care Specialist
 

·
Registered
Joined
·
933 Posts
I am having the same problem with my 2012 ram 3500 did you find a fix
Hi Opie2280,

We are sorry to hear that you are also experiencing this concern with your vehicle. Have you brought this to the attention of your dealer? Please send us a PM if additional assistance is needed.

Darlene
Dodge Social Care Specialist
 

·
Registered
Joined
·
2 Posts
Yes it's at my mechanic shop he told me the ecm was bad put a new one in it went picked it up 10min down the road same thing took it back haven't heard back from him yet
 
1 - 8 of 8 Posts
Status
Not open for further replies.
Top