DodgeTalk Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Getting a P0443 code on a 1998 Ram 1500. The is a "circuit" problem.

Evap purge solenoid is new. Even so it is closed when removed from the system and when I apply voltage and ground I can feel and hear it open. So I don't think the problem is here.

With the key on/engine off:

At the connector on the blue/white (should be pin 2), I have 13v. This makes sense as far as I can tell it is coming off the fuse so this should be the positive side.

At the connector on the pink/white (should be pin 1), I have 5v.

I have tested the pink/white from the PCM connector to the evap solenoid connector and there is a 0.2ohm resistance.

At the PCM C3 connector pin 20, there is 5v. I don't know what this value should be.

I have done a pretty thorough goole search and have come up with nothing. I can "bypass" this and make no code show up by using a resister across the connector but I would rather figure out what it really is.

Any ideas on further trouble shooting?
 

·
Registered
Joined
·
139 Posts
I believe 13V to be prolly battery voltage to actuate solenoid. 5v is usually logic voltage from PCM. 0.2 ohm on wire from PCM isn't a good tell. Try putting either a headlight or running/blinker light to the battery thru the wire, so you can "load test" the wire. MAKE SURE THE PCM IS DISCONNECTED FOR THIS TEST!!! Also possible that the purge valve is filled with charcoal canister pellets from a bad charcoal canister for the gas tank. good luck!
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Thanks for the info. I should borrow an oscilloscope from work and monitor that line :). I am going to get the emissions done with it being fooled this weekend so then I can have some time to really figure this out.
 

·
Registered
Joined
·
42 Posts
I had an error that was telling me the control circuit for the purge solenoid was bad.. I could hear the solenoid clicking on and off from time to time.. What I found was a poor socket connection to the purge solenoid. I grabbed a socket from the junkyard and replaced it with some dielectric grease and no other issues.
 

·
Registered
Joined
·
2 Posts
Is there any way to by pass it ? I just bought a 1998 dodge ram 1500 and one of the codes its giving me is P0443. Also i dont know why the canister plugs into. I can not find the plug to plug it in but the hoses are on. I need help. Also the truck when i want to accelerate it doesnt really accelerate or move, it just starts sputtering and acting up and it like bogs down.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top