DodgeTalk Forum banner

Status
Not open for further replies.
1 - 10 of 10 Posts

·
Registered
Joined
·
364 Posts
Discussion Starter #1
where is that at??? i crawled up under my truck and seen like 4 or 5 sensors going to the block and none of them look like the part i ordered.... It's hard to start do you think i broke a vavle spring????
 

·
Registered
Joined
·
364 Posts
Discussion Starter #2
Anybody???
 

·
Previously Micash21
Joined
·
2,802 Posts
When you attempt to start the truck, does your RPM needle move?
 

·
Previously Micash21
Joined
·
2,802 Posts
The crankshaft position sensor is on the right rear of the block
 

·
Registered
Joined
·
364 Posts
Discussion Starter #5
When you attempt to start the truck, does your RPM needle move?
It spins over a few times not moving then the rpm gauge then will jump then it cranks and runs real ruff i put it back on stock tune
 

·
Registered
Joined
·
364 Posts
Discussion Starter #6

·
Previously Micash21
Joined
·
2,802 Posts
Yea, passenger side rear.
 

·
Registered
Joined
·
364 Posts
Discussion Starter #8
Ok cool thank's... I just hope it is a bad sensor and nothing else i,m about to be doing a came swap
 

·
Previously Micash21
Joined
·
2,802 Posts
A bad crank position sensor can worsen the way the engine idles, the pistons fire, or the acceleration behaviour. If the engine is revved up with a bad or faulty sensor, it may cause misfiring, motor vibration or backfires. Accelerating might be hesitant, and abnormal shaking during engine idle might occur. In the worst case the car may not start.

Hopefully this cures your issue.
 

·
Registered
Joined
·
364 Posts
Discussion Starter #10
yea i hope i so to... When the light came on my engine was at about 6500rpms
now it wont go over 3500...
 
1 - 10 of 10 Posts
Status
Not open for further replies.
Top