DodgeTalk Forum banner

Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
138 Posts
Discussion Starter #1
Alright this is what happens. i start my truck and starts kinda rough but still runs and it idles fine then ill give it a little gas and as soon as i let off the gas pedal the truck drops below 600 rpms and the engine dies. anyone have any idea what the problem is?
 

·
Former Ram owner
Joined
·
425 Posts
try the throttle position sensor. Mine did the same thing about a year ago and all i had to do was clean it. I took it out (very easy to get to, just pop off your intake and you should see it) and sprayed it with some brake cleaner, hit it with some wire brushes until it shines again. Give that a shot and see if it fixes it.
HTH

Kenny
 

·
Registered
Joined
·
10,824 Posts
ya, and if you need to replace it the sensor runs arounjd 35-45 bucks new.
 

·
work in progress
Joined
·
1,709 Posts
it sounds like the idle air control sol. on the back of the tb pull the tb off removev the sol and clean it up you should be fine
 

·
Former Ram owner
Joined
·
425 Posts
sorry... i didnt mean the TPS... I meant the IAC. I ended up replacing both when I did mine, and mixed them up in my post. Is a TPS even clean-able??? lol
 

·
Registered
Joined
·
138 Posts
Discussion Starter #6
i fixed it well i took it to the shop and had them hoook it up to the computer. i found out it was some sensor the guy told me to buy a bottle of that cheveron techron stuff and run it through the tank and it works fine now :p thanks guys for the the help you were right it was just a sensor
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top