DodgeTalk Forum banner
Status
Not open for further replies.
1 - 6 of 6 Posts

· Master Of The SNAFU
Joined
·
240 Posts
Discussion Starter · #1 ·
Hello everyone-

Quick question from a dumba$$ here. Last time I went to the dealer for an oil change, I asked them to use synthetic oil on the oil change. I went to the dealer for the change because the first one was included with my truck purchase. The service advisor there suggested I NOT use synthetic until the truck hit about 30K miles because he said that some of the seals/gaskets may not seal right until the motor has a few miles on it. I went with conventional oil for now, has anyone heard of this?

Also, I have been told that once you run synthetic if you change back to regular oil the rings may start to blow by and you may actually burn oil. Any truth to this?

And what are you running for synthetic or oil additives?

My truck is a 2004 Ram 2500 Hemi, now has about 26K on it.

Advice, anyone?
 

· Registered
Joined
·
489 Posts
26k it should be broken in'next oil change go ahead and make the switch. No additives required and dont worry about seals
 

· Banned
Joined
·
11,103 Posts
Rammitall said:
The service advisor there suggested I NOT use synthetic until the truck hit about 30K miles because he said that some of the seals/gaskets may not seal right until the motor has a few miles on it. I went with conventional oil for now, has anyone heard of this?

Also, I have been told that once you run synthetic if you change back to regular oil the rings may start to blow by and you may actually burn oil. Any truth to this?
That's a myth about the seals/gaskets and synthetics.

You can switch back and forth from conventional and synthetics.

I've run synthetic motor oil for most of the 40,000 miles I have on my truck. No issues. :)

Sil
 

· 2012 Texas Ram Express
Joined
·
4,203 Posts
i think im gonna be switching to synthetic at the next oil change, after using Mopar oil from when i got the truck new, till when i get it changed next at 20,000 miles. At 17k something now.
 

· Registered
Joined
·
1,731 Posts
I hate to be a sore thumb but when i switched to synthetic at 9,000 miles i burnt oil when i first started up. Took about a month but it stopped and now and it runs great, no problems at all. I don't know if it was the oil or how cold it was (It got down to -30)
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top