DodgeTalk Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
My 97 Intrepid starts and runs great but after I drive it around 20 miles and it warms up the oil light comes on and some of the lifters start tapping. I can shut it off for an hour or so and it sounds perfect again. Does anyone know what the problem might be? Thank you!
 

·
Registered
Joined
·
204 Posts
Sounds like maybe the oil pump is not able to pump up oil.
Could be a blocked oil filter, but unlikely.
If our cars have a pickup screen at the oil pan, it may be getting blocked. This happened to me on a Ford Ranger and took dropping the oil pan to find the problem. Same sort of description as you....I'd run it and the oil pressure guage dropped to 0. Turn off and let sit. Start again and fine for a few days.
My dad just cut the screen out and said the filter does the work.

KP
 

·
Registered
Joined
·
1,514 Posts
Has it had a recent oil change? If not, it needs one. Oil loses viscosity over time and becomes thinner, especially the warmer it gets. If changing the oil with recommended style oil doesn't fix it, you have either an oil pump clogging,going bad or worse bearings failing. Either case the oil pan needs dropped to find out. If you drop the oil pan and find bearings going bad, the only temporary fix, unless you want to spend the money to rebuild it, is to go to a thicker oil. Instead of 5w30 use 10w30 or instead of 10w30 use 20w50. Oil is read this way. The 5 or 10 or 20 before the W is what viscosity the oil is at hot. The numbers after the W are the viscosity of the oil when cold. Thicker oil gives higher oil pressures. This is only if the bearings are worn out, it will get worse even using thick oil. You will need to rebuild that engine or get a different one eventually, or get rid of it before it starts doing it again. If the oil pan is pulled I would try a new oil pump or rebuild the existing one if I couldn't find a rod bearing going bad,by trying to wiggle them. They should have very little side to side movement but no up or down. If you replace or rebuild it and you still have low oil pressure then either main bearings are going bad or camshaft bearings. The only way to check the mains is to drop the caps while the pan is off. They need torqued to specifications and aren't advised to remove unless you are replacing them. The same goes for the rod caps. Disturbing their seat can cause further failure faster. Each time you hear the valve chatter damage is being done to the engine. The valve chatter is a sign of not enough oil being delivered.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top