DodgeTalk Forum banner

Status
Not open for further replies.
1 - 20 of 23 Posts

·
Registered
Joined
·
357 Posts
Discussion Starter #1
is it possible to have a bad o2 sensor and not have the check engine light come on, just trying to figure out why my gas mileage sucks so bad.
 

·
Registered
Joined
·
2,627 Posts
did you just notice your gas mileage get very poor or has it been like this for a while? ive had sensors go bad its taken a while for the CEL to come on.
 

·
Registered
Joined
·
357 Posts
Discussion Starter #4
about 2 months ago, so i checked the plugs (there new)thought maybe it was the gas, but now am thinking it could be the o2 sensors, what do you guys think? lets get some input because my mileage really sucks bad....
 

·
6.1 FTW
Joined
·
2,307 Posts
I think yes it is possible. Does the 03 just have a single pre-cat O2 sensor?

The 04+ I know have one for each bank and in that case if it was completely failed you would know it. I had one failed on just one side and the engine vibrated so bad it was like it was going to jump out of the truck. Replaced the O2 and all was good. I DID get a code for that - but it was a complete failure.
 

·
6.1 FTW
Joined
·
2,307 Posts
I mean the pre-cat sensors only. I think the 03 just has one. The later models have 2 (for a total four), but I'm not totally sure on the 03.
 

·
Registered
Joined
·
357 Posts
Discussion Starter #10
1 in front of the cat and 1 after the cat
 

·
6.1 FTW
Joined
·
2,307 Posts
OK. In that case yes its probably a good idea to swap it out. On an 04+ you would have other issues (like vibration) if only one sensor was bad, on the 03 you only have the one so it could be biased and the only indication would be running rough, poor mileage, etc.

Are you getting a real rich exhaust smell or anything?
 

·
Registered
Joined
·
2,627 Posts
after 2 months a bad o2 sensor should have thrown a code. when my o2 went, i didnt even notice any difference in power or mpg...before and after changing it. i guess it could be possible that its your problem, but id be a little hesitant buying a $100 sensor if i wasnt sure that was the issue.
 

·
Busted Knuckle Garage
Joined
·
531 Posts
Is it just me or does anyone else think the mileage "problem" is that it is a pre MDS quad cab 4x4 with 33's?
 

·
6.1 FTW
Joined
·
2,307 Posts
That's what he is saying. That without MDS and running 33" tires you should expect sucky gas mileage. I assume your complaint about gas mileage is because you saw a sudden drop-off though, not because you added 33" tires!
 

·
Registered
Joined
·
357 Posts
Discussion Starter #16
you are right! had the 33"s for a year now, mileage just dropped off for no reason. well what i thought was no reason
 

·
Admin - David Mack
Joined
·
30,924 Posts
If you do not have any CEL's, I find it very hard to believe the O2's are bad.

:imo
 

·
Registered
Joined
·
357 Posts
Discussion Starter #18
thats what am thinking, but what else could be the reason for bad gas mileage all of the sudden
 

·
Busted Knuckle Garage
Joined
·
531 Posts
What were the numbers before and what are they now? How much of a change have you seen?
 

·
Registered
Joined
·
357 Posts
Discussion Starter #20
i went from getting 12 to 15, currently getting 10 to 7mpg
that sucks....
 
1 - 20 of 23 Posts
Status
Not open for further replies.
Top