DodgeTalk Forum banner
Status
Not open for further replies.
1 - 14 of 14 Posts

· Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
:help: Well i'm new to this site and kinda new to dodge trucks..
Just bought an 89' Power Ram 350 4x4 with a 4 in lift and 35 BFG A/T's
Dana 60's in the front and rear with 4.10 gears, running a 360 gas with the throttle body inj system.. oh and it's 3 spd auto. Awesome condition truck no a/c but i don't need it. I'll send pics soon.
Well it's gettin horrible gas mileage guys.. Looked at the injectors and they seemed clean.. changed the cap and rotor and pcv valve, waitin till next week for some money to put a set of plugs and wires on it.. and i changed the fuel filter.. Tightened down the Throttle body to the manifold and looked at the EGR looked dirty gunna get a new one of them too...
But what can i do to get better mileage.. (don't know exactly the gas mileage but it's bad, since the speedometer don't work right now) filled up last thur and barely drove around this weekend and it sucked down half a tank!!
Oh it has around 135,000 on it with motor work done to it (don't know what but the dude said the guy he got it from did work to it). Doesn't have a CAT on it or an O2 sensor bc it has flowmasters on it.. But she runs bought as smooth as a brand new motor and the exhaust is VERY VERY strong with fumes and it feels moist so i know she's burnin way rich but how to get it to burn more lean?? no adjusments!! :VHOT: Well if anyone out there can help me or if you have any questions... HELP ME OUT!! :thatfunny
 

· Registered
Joined
·
181 Posts
your spark plugs should be gapped at 0.35 over. if you want to go leaner, just lower the LBS of the fuel pressure. i see that all the time on chevys :eek: they just drip that extra gas. i guess thats why we have our dodges :D :gr_patrio i would get a K&N filter that will give you like an extra MPG.

brandon
 

· Registered
Joined
·
55 Posts
also consider the 260 v8 did not have that great of mpg any way!! Also with the bigger tires you will create more drag and road friction. But sounds like a sick truck
 

· Registered
Joined
·
55 Posts
360 v8 sorry what was i thinking
 

· Registered
Joined
·
287 Posts
Without the O2 sensor it's never going to regulate the fuel properly, besides it's a 360 Dodge,it don't get fuel milage.
 

· Registered
Joined
·
9 Posts
Discussion Starter · #8 ·
Well i guess maybe i should put a O2 sensor back on it,since it would make sense right? Well i put a cap and new rotor on it along with a fuel filter and PCV valve and it seemed to up the mileage a lil bit, gunna get some new plugs and wire for it too.. Oh and it backfires some times when i'm goin like 55-60 when i let off the gas and the backfires are followed by black/brown smoke, so i'm guessin thats the plugs and it burning rich right? well thanx for the info you guess are givin me
 

· The Legendary Cross Ram
Joined
·
3,730 Posts
350DodgeBoy said:
...Oh and it backfires some times when i'm goin like 55-60 when i let off the gas and the backfires are followed by black/brown smoke, so i'm guessin thats the plugs and it burning rich right?...
You bet it is running rich, waaayyy rich! So rich in fact, that it sounds like you have a pretty bad carbon buildup. What you need is to replace your O2 sensor where it belongs, so you may need to call the dealership to find the correct location (the ECM contains calibrations relying on the O2 sensor being located in a critical part in the exhaust system).

360s can get decent mileage if everything is working correctly and it is driven very nicely. :cool:
 

· The Legendary Cross Ram
Joined
·
3,730 Posts
AMP762 said:
...Without the O2 sensor it's never going to regulate the fuel properly,...
You're right on target in your thinking. :cool:
 

· Registered
Joined
·
9 Posts
Discussion Starter · #12 ·
Well hey i found the O2 sensor (not in the place i thought it would be) on the driver side of the motor right under the exhaust manifold and it's pluged in but i guess it really needs replacement.. I thought that O2's are supposed to be where the pipes coming from either side of the motor come to a Y so it reads all exhaust? I priced it and i'm gunna buy it along with some better plugs (any suggestions?). Hopefully that sensor is causing all of this mess. I ran the codes from the check engine light when i plug it in and it says somthin about the speed sensor and that the computer was un pluged within the last 51 starts,so whatever that means??
 

· Registered
Joined
·
2,135 Posts
If you have an Autozone nearby, get your O2(Bosch OE type) there, also a set of Champion Truck Spark plugs and get a Coolant Temperature Sensor-this is the sensor that tells the computer what temp the coolant is at so that it can regulate fuel mixture and timing. There is another sender that is used for the dash gauge...they are two different parts-so get the correct one, you dont want the one for the dash gauge. :D
 

· Registered
Joined
·
9 Posts
Discussion Starter · #14 ·
Thanks alot, yeah i think the coolant gauge or sensor isn't workin properly, either that or the engine runs very cool?? Because the gauge just always reads like one line over the C mark when the motor warms up...
 
1 - 14 of 14 Posts
Status
Not open for further replies.
Top