DodgeTalk Forum banner
Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter · #1 ·
I am not getting any signal to the trailer. I have checked the power source and it is connected to the fuse panel. Is this the only place to attach the power source to? The wires that are connected to the turn signals are correct. I know that the lights on the trailer work because my buddy hooked his truck up to them and they worked fine. :banghead:
 

·
Patriot....
Joined
·
3,375 Posts
did you get a kit that plugs directly into the OEM lights or is this a cut/splice? Start with the ground and work from there.
 

·
Registered
Joined
·
3 Posts
I am having same problem. had a hitch/wiring installed. bought a trailer and no power to trailer at all. I was reading some posts and looked into my fuse box. there's a place in the box for 2 relays that are missing. the label for the slots refers to towing. could missing relays be answer?
 

·
Registered
Joined
·
2,375 Posts
yes, you need to get the charging relay and if needed the trailer brake kit from Dodge, Chevys have same deal (go to dealer)........Fords come with everything you need including the trailer brake connector........
 

·
Registered
Joined
·
3 Posts
missing relays the answer

Found the answer to my problem. If you don't get the factory trailer package, Dodge leaves 2 relays out. The empty slots are in the power box on driver's side front of car. $10 ea, they pop right in and you have power to the harness.
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top