DodgeTalk Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
So I got one from the auto salvage off a Chrysler 300,all is connected but now it won't crank or start I here a click noise from the back of the air intake and from the back of where the battery and fuse box is any questions why its doing this and how do I fix it
 

·
Registered
Joined
·
465 Posts
So I got one from the auto salvage off a Chrysler 300,all is connected but now it won't crank or start I here a click noise from the back of the air intake and from the back of where the battery and fuse box is any questions why its doing this and how do I fix it
What modifications have been made to this car? Harnesses don't catch fire without a reason. There was obviously a severe short or overcurrent situation. There could be blown fuses or burned out relays....among other problems.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
My fuel line that's on the top back air intake.well I guess some how the connector' came off and that's when it caught fire and damaged the passenger siege of the engine harness. So I went to the autosalvage and grabbed a used one cause I can't afford a new one.So OK harness installed and now security mode is on.I buy passed it and it turns on but due doesn't stay on its rough idleing, and its never rough idleing and doesn't stay on..hummm wat could I do to fixed this plz help cause its sarting to piss me off already
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
OK here's my situation, I blew a head gasket and #8Cylinder head piston was mashed up but everything els was good thank you jesus.so I broke it down sent heads to the Machine Shop and got the gasket set,new coil,pks new plug wires ,I did a complete over haul on my Magnum RT.go to test drive to see how the 5.7 Hemi is gonna run and I'm at the stop light well I noticed black smoke coming from the hood ,so I jump out and so does a city worker that was next to me and puts it out with his fire extenguiser,that's when we both notice the top passenger air intake fuel like be had came off.and pretty much caught alll of my passenger side harness and connectors.yeah that suked
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
OK so I finished, installing the engine harness and a new battery,now the security mode is on and I did the reset and it started but man she's rough idleing and doesn't stay on.she sounds like shit..my 5.7 Hemi never rough idled, and she use to sound smooth,and had Balls,I would be eating up mustangs and camaros,like nothing,so wat could be the problem on why my car won't stay on and is rough idleing, I pretty much overhaul it my self and it has new oil,new plugs ,newcoil Pak's ,new water pump,/Thermostat, new fuses,relays, and "" a well"" not new but used Harness"anybody got any answers or can you lead me to the fixing solution, cause I'm ready to haul some ass in my Magnum RT 5.7Hemi.but I can't until I fix this issue plz help
 
1 - 5 of 5 Posts
Top