DodgeTalk Forum banner

Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter #1
I can't figure it out, since last week I have been using close to a third more fuel than i normally would, i'm not in 4x4 or driving any different, and my digital mpg reading is the same as well. But i can't smell gas anywhere so It's not leaking i don't think. Any ideas? 9.7 mpg was bad enough, now I'm getting around 10 so says the readout, but my tank says other wise. Please help.
 

·
R.I.P Big Blue
Joined
·
5,326 Posts
Are you letting it idle longer in the cold? Spinning more taking off in the snow? And I don't mean to call you stupid, but did you actually do the calculation for milage, or it just seems like it isn't really getting 10mpg? I know mine gets about 4mpg worse in the winter, due to all those reasons and more, and watching the guage, you'd think I was getting even worse than that, it's a mental thing.

If not any of those reasons, have you changed anything on the truck? Went to a different gas station? Different Octane/Ethanol?
 

·
Registered
Joined
·
45 Posts
Discussion Starter #3
Ya, sorry for taking so long responding, i found out the reason for it. Water in the fuel. The other reasons i was was pretty sure i calculated the effects of snow and spinning and pre idle time. But ya i filled up at a different station and added some antifreez gas line fuel. Thanks for your reply though very much. Oh and got a AEM brute force intake today and installed it. Works awesome and sounds great too.
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top