DodgeTalk Forum banner

Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
61 Posts
Discussion Starter · #1 ·
I just recently went mudding in my 99 1500 4x4 and while I was in 4wd pulling another vehicle out, I heard a loud noise like a thump noise coming from my front axle... I didn't pay much attention to it but today driving on the highway in 2wd I keep hearing it every now and then, but almost always while turning... its like a thumping or loud clicking and I can sort of feel it in the floorboard... I changed both of the U joints on the front end about a month ago so I dont suspect its them. Has anyone had this happen to them and what was the problem?
 

·
Registered
Joined
·
10,824 Posts
that is a hard one. i was going to say u-joints but since you replaced them a month ago that should not be it. i would still go ahead and check them out to make sure. good luck
 

·
Registered
Joined
·
11 Posts
Are you turning when this noise happens? I get that when I turn sometimes due to the lugs on my tires. Hope this helps.
 

·
The Green Machine
Joined
·
1,722 Posts
Did you change the axle U-joints or the driveshaft U-joints (or all of them)? 'Cause it sure sounds like a U-joint issue...

When's the last time you changed the hub unit-bearings? They'll usually squeak/squeal rather than clunk or thump, but they're worth checking on too.
 

·
Registered
Joined
·
2,040 Posts
I vote u-joints too. Especially after reading your sig line and mod list. Check those ujoints again.
 

·
Registered
Joined
·
61 Posts
Discussion Starter · #6 ·
thanks for the input guys... after driving the truck today I think it may be something with the motor rathr than the axle/drive shaft... I will start a new thread about what I experienced today and your input is greatly appreciated
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top