DodgeTalk Forum banner
Status
Not open for further replies.
1 - 2 of 2 Posts

·
Registered
Joined
·
47 Posts
Discussion Starter · #1 ·
Hi again,

Just got the van back from the garage this weekend so I went for a drive to test everything. The good news is that I now have heat (new thermostat) and gaz gauge (new float in tank) plus new upper ball joints and alignment.

The bad thing, as the title says, is that it is pulling to the left when I'm braking. I've never noticed before as it only shows when I'm braking a lot. On smooth braking it doesn't do it or at least I don't notice it.

So, what it does is pull to the left a bit enough that I need to turn the wheel maybe 5 - 10 degrees to the right to correct the path. I've read stuff about a frozen caliper but these are drum brakes. Any idea on what to check ? I'll probably bring it back to the garage monday as the trans back seal they changed is leaking... Had probably around 2 oz of trans fluid in my driveway... That's the good thing about snow. It makes these leaks stand out ;-)

Have a great day and a happy spring to all.
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #6 ·
You are right that it's discs in front / drums in back.

So, we found out that the cylinder on one side was done. This was changed on both sides just to be sure as were the rotors. They were not dead yet but would have been soon. Both hoses were changed in the back too. The rubber ones.

A test drive showed that it resolved some of the problem but not all. So we looked at the front, changed the two hoses (they were a bit kinked) and found that the two calipers were different. These were also changed and now it's steering quite fine !

Turns out that TXwooley was right. I don't know who had the idea to put different calipers in front but now they're the same. It's a good things that parts are not too expansive on that van... Now we should be all fine to get to the south in a couple of weeks.
 
1 - 2 of 2 Posts
Status
Not open for further replies.
Top