DodgeTalk Forum banner
Status
Not open for further replies.
1 - 20 of 38 Posts

·
Registered
Joined
·
53 Posts
Discussion Starter · #1 ·
hey guys this is my first time here so be nice..haha. i have an 03 1500quad cab SLT/SXT. i recently have been getting "lamp out" blinking and the beeping just wont stop..or the ring, whatever. i asked around and they say it rings and blinks b/c a bulb is out. ive checked every blinker, light, bulb whatever and still nothing. do you think this is just an electrical short somewhere and i need to take it into the shop and get something resetted?? please help cuz i dont have a darn clue. i appreciate everyones help in advance, thanks so much. i'll post pics of my truck later....
 

·
Banned
Joined
·
3,852 Posts
songho79 said:
hey guys this is my first time here so be nice..haha. i have an 03 1500quad cab SLT/SXT. i recently have been getting "lamp out" blinking and the beeping just wont stop..or the ring, whatever. i asked around and they say it rings and blinks b/c a bulb is out. ive checked every blinker, light, bulb whatever and still nothing. do you think this is just an electrical short somewhere and i need to take it into the shop and get something resetted?? please help cuz i dont have a darn clue. i appreciate everyones help in advance, thanks so much. i'll post pics of my truck later....
Cant help with you lamp...but wanted to take the time to say Welcome to DodgeTalk. Hope someone helps you out.....................Later
 

·
Banned
Joined
·
2,221 Posts
Wasinger12 said:
Cant help with you lamp...but wanted to take the time to say Welcome to DodgeTalk. Hope someone helps you out.....................Later
WELCOME TO DODGETALK!!!!!!!!!!!!

i've had that 'lamp out' problem. dunno where they got the torture device chime but it's torture.

my local dealership replaced this under warranty. i suspect they'd do it even if you're warranty is out. i am pretty sure it was a recall on the whole board where the light bulbs plug in in the tail lights.
hope this helps.
bob
 

·
Tank Mech
Joined
·
3,687 Posts
Welcome to DT!

One thing you can do is check each and every bulb that's covered by the "Lamp Out" circuit (Tails, Brakes, Turns, and Headlights... including the cyclops stop). You have to physically look at each one. Even though it lights, a bulb could have a corroded base which will intermittantly lose connection, setting off the "ding." Also, the system monitors the bulbs even when they aren't in use, so don't dismiss a particular bulb as the culprit just because it wasn't being illuminated. Hope this helps....
 

·
Registered
Joined
·
23,005 Posts
I had the same problem. Was my left rear tail light bulb assembly.

KB
 

·
Registered
Joined
·
35,849 Posts
Its a known issue on the 03's. They need to replace the drivers side tail light circuit board. There is no TSB or recall on it but when my 03 did the same thing my service manager knew what it was right away. He said he already had fixed 5 of them. After he replaced my drivers side board I never had the problem again.
 

·
Country Style
Joined
·
4,927 Posts
Is this circuit board in the taillight assembly or in the wiring going to it? I am occassionally getting the lamp out on mine, but have aftermarket taillights. It usually happens when I hit a bump so I might just have a loose bulb. Did I get rid of the circuit board when I changed out the taillights?
 

·
Registered
Joined
·
35,849 Posts
Circuit board is part of the light assembly
 

·
One day at a time
Joined
·
1,003 Posts
I had the same thing happen and it wasn't a bulb. I had installed a K&N CAI and had to undo a ground strap on the passenger side to get the factory air box out. I put it back in its orginal place but it wasn't grounded enough, but that was it the lamp out light has been off ever since. I have a 03 and everyone told me about the circuit board but it was'nt that at all. That light out is very sensative. It took several trips to the dearlership until they finally found it. I about went crazy with all the beeping!
 

·
RamByBlood
Joined
·
1,309 Posts
mullinax05 said:
I had the same thing happen and it wasn't a bulb. I had installed a K&N CAI and had to undo a ground strap on the passenger side to get the factory air box out. I put it back in its orginal place but it wasn't grounded enough, but that was it the lamp out light has been off ever since. I have a 03 and everyone told me about the circuit board but it was'nt that at all. That light out is very sensative. It took several trips to the dearlership until they finally found it. I about went crazy with all the beeping!
I've had the same problem, well except I didn't go to the dealer I figured it out since it started happening shortly after I installed my cold air intake system as well.
 

·
I'm just saying...
Joined
·
135 Posts
I had it happen on the driver's side as well. What a painful hour and a half drive. No matter how loud I turned up the radio I could still hear the dinging. I knew exactly which bulb it was, but there was nothing I could do about it. I replaced the buld and was okay, but I suppose I should probably have that board replaced. It looked like it had gotten really hot and melted the plastic around the contacts on the light.
 

·
C HEMI GO
Joined
·
1,739 Posts
Keep in mind that some bulbs (like brake lights) are dual filaments. Just because they are on, doesn't mean they're good.

Go buy a handful of bulbs and swap them all. After 3 years, they are gonna start going out for real soon anyway.
 

·
Totally Hemi Crazy!
Joined
·
321 Posts
I had this on my '03 also and it was one bulb rear drivers side. You could see that the bulb was not making a real good contact and had electrical burn on it. I used a thin screw driver and pried out the bulbs contacts to make it wider and fit more snugly and it has not reoccured.
 

·
Registered
Joined
·
513 Posts
this JUST happened to me this week
the problem is you have an intermitant bulb (its almost out- PROLLY A TURN SIGNAL)
mine was my rear turn signal... you can find out by flipping ur turn signal on in either direction when the "Lamp out" comes on... if that turns it off, that means its that signal (front or back i dont know) i just waited 2 days till it burnt out
 

·
Registered
Joined
·
53 Posts
Discussion Starter · #19 ·
hey guys..it finally went out..the rear light turn signal..drivers side...whew..that was pissing me off...i drove a good 2k miles before it finally went out. what happned was..one night i noticed while remote locking my car, one side of the car didnt light up...then i used the turn signal and it was ticking unusually faster than normal..so it was that side...thanks again for everyoens comments and concerns..take care!!
 
1 - 20 of 38 Posts
Status
Not open for further replies.
Top