DodgeTalk Forum banner

Status
Not open for further replies.
1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
My new-to-me 2k Durango has an irratic - intermitant idle issue. The idle speed at stop with brake on drops from norm of 650 to 300ish, coughs and sputters. When gas is applied slowly, smoothly or quickly, the motor pops and sounds like a "backfire" and then smooths out, and runs fine. If the trans is put into Park, it smooths out and runs fine. If the vehicle is parked and turned off for any length of time, all is well when restarted.

All this happens only after normal op temp - 190ish is reached and has been running for more than 30 minutes.

I bought the car 2 weeks ago and have driven it 600 miles. It has 61k and performs wonderfully except for this issue.

! Ideas Please !
 

·
Registered
Joined
·
4,953 Posts
Which motor? Any codes? Questions, questions...
 

·
King Daddy D.O.G!!!
Joined
·
2,475 Posts
WarrensD said:
Which motor? Any codes? Questions, questions...
Warren is becoming the resident Signature and Code Police. LOL

Gotta know the engine size and which codes are being thrown out!
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Irratic Idle -continued-

The motor is a 5.9, auto trans, 2wdrive, all factory stock.

? Codes ? I don't know how to "get" codes. Can they be displayed somewhere in the dash display?

Thanks
 

·
Pimp On Sir Don
Joined
·
12,782 Posts
Does it SOUND like it's backfiring or does it just sound like it's revving down. Backfires are like a gun shot. It will pop etc as it revs down.

Probably a TPS issue with low voltage. Check the voltage on the TPS. It should be reading somewhere between .6/.8 or so.
 

·
Registered
Joined
·
3,722 Posts
Try cleaning the idle air motor. The idle air motor is on the back of the throttle body. It meters air into the engine at idle when the throttle blades are closed. It can get gunked up and not regulate the air correctly. Take it off and make sure the seat and shaft are clean. Also make sure the passage in the throttle body are clean. Use carb or throttle body cleaner.
 

·
Registered
Joined
·
4,953 Posts
WMB 2kdurango said:
The motor is a 5.9, auto trans, 2wdrive, all factory stock.

? Codes ? I don't know how to "get" codes. Can they be displayed somewhere in the dash display?

Thanks
To retrieve the codes, turn the key to the "on" position (not start), then "off" (not Access), then "on," then "off," then "on" (within four seconds). Be prepared to write down the codes which will appear in the odometer window. Come on back with any codes & we'll get BUSY!
 

·
Registered
Joined
·
3 Posts
Discussion Starter #8
Codes and Irratic idle

Checked for codes as you described. Display message was "P done".

Does this mean there are no codes "saved" in ther vehicles system?

My idle problem still exists and very intermitant - irratic. About the only pattern is: full Op Temp, running at least 30 minutes. The issue does not occur unless these conditions have been met, but not every time.

? Ideas ?

WMB
 

·
Registered
Joined
·
151 Posts
Rule of Thumb Test

With the D off, mash the gas down 5 or 6 times to the floor. Now start it and examine the idle quiality. Has it smoothed out? If so, replace the TPS with a Wells brand TPS.

Still rough? Remove and clean the IAC as suggested above. These get very carbonized and cause idle fluctuation. Some do it every tune up. I do, along with cleaning the entine TB.

HTH
 
1 - 9 of 9 Posts
Status
Not open for further replies.
Top